summaryrefslogtreecommitdiff
path: root/app-doc/clsync-docs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-doc/clsync-docs
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-doc/clsync-docs')
-rw-r--r--app-doc/clsync-docs/Manifest5
-rw-r--r--app-doc/clsync-docs/clsync-docs-0.4.1.ebuild49
-rw-r--r--app-doc/clsync-docs/clsync-docs-0.4.2.ebuild40
-rw-r--r--app-doc/clsync-docs/metadata.xml18
4 files changed, 112 insertions, 0 deletions
diff --git a/app-doc/clsync-docs/Manifest b/app-doc/clsync-docs/Manifest
new file mode 100644
index 000000000000..9a36f80cf8f3
--- /dev/null
+++ b/app-doc/clsync-docs/Manifest
@@ -0,0 +1,5 @@
+DIST clsync-0.4.1.tar.gz 253890 BLAKE2B c8aada690635f1cac355a1eaa51f4379688b0005869c5dcd6edccf5ae8e86abddf9ff99ccfcffeb165ccc80f407087a3f0863d1b78279894ff410daf25467740 SHA512 875280f706026d44806b92c22fa58d016136b2792f67a6b7e77f932465081da7a1ebaf22c25e538e4b58bfe04cd1cd5450ecab99c3df53ddd2a0fa966442d444
+DIST clsync-0.4.2.tar.gz 256042 BLAKE2B 28474fc66341b93705a502fcff390e3affcd89a9e1eb272dce9b28be709562e09c03e9c300cfeb5371e2e618a2239468a58c46212a39d751fbbfddeaab12bcf6 SHA512 d14a2efc4bf58d9d5c7a3fe5634cacdd182cd7cd814b0e9ebd99024a7282b056d1f7ceeec6903666391c3572d599a18e205af818b098ed7768d5c0e0f4cd1200
+EBUILD clsync-docs-0.4.1.ebuild 1042 BLAKE2B 33248ab05c8f6f230c3a2239db63e0a8e4b7df6256c8dffe3f8ea03bdd621675e2780ce163e5a68bbd2e0c1b1de164da5168e4d445563d4115e3dd4ed6087876 SHA512 f92c8752dcec8d46a76d748a679baf4ed857cfd7261184f11b8ba43ddbc8780490a7b0c089bde4f4853efd0e6d8544efb7e4377dbe15a68000a0e1a5afd7a03b
+EBUILD clsync-docs-0.4.2.ebuild 889 BLAKE2B 04dd3168a1b27a2a1cd5ef36216b138fc116258e1095caf94ae29e5200c39ceb5fc2c2a7dcd039ec5eec4770738ed66781f8452a434d5f287978fa706cc2751c SHA512 db90d42739b569cff772b81a7b71fb8a9e56df0f97fdd1d155e81a59c04723046579330a48e5b30a55e40ba021277e2e247ed2d60474c9153d6f302e5d2a20bb
+MISC metadata.xml 569 BLAKE2B affa352674c37363d695f97f53015f89769c91a1e6ddb35d6a7f4a12e161fd266841f1d2bcc630ef0807c8bb936835e7cf50b26dc3630c718364fb8bc027910d SHA512 21485b31c70a686ff1cbb5af951f4ab0a89841878cda664a396561dd683349c857c0485551c77c924677b4542b35b08ff55b11ca3c20176531bf7e4a1b05f60b
diff --git a/app-doc/clsync-docs/clsync-docs-0.4.1.ebuild b/app-doc/clsync-docs/clsync-docs-0.4.1.ebuild
new file mode 100644
index 000000000000..f4943eef407f
--- /dev/null
+++ b/app-doc/clsync-docs/clsync-docs-0.4.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+MY_PN="${PN%-docs}"
+MY_P="${MY_PN}-${PV}"
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/xaionaro/${MY_PN}.git"
+else
+ SRC_URI="https://github.com/xaionaro/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${MY_P}"
+fi
+
+DESCRIPTION="Clsync and libclsync API documentation"
+HOMEPAGE="http://ut.mephi.ru/oss/clsync https://github.com/xaionaro/clsync"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="api +examples"
+
+DEPEND="
+ virtual/pkgconfig
+ api? ( app-doc/doxygen )
+"
+
+src_configure() {
+ : # doxygen doesn't depend on configuration
+}
+
+src_compile() {
+ if use api; then
+ doxygen .doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ dodoc CONTRIB DEVELOPING NOTES PROTOCOL README.md SHORTHANDS TODO
+ if use api; then
+ dohtml -r doc/doxygen/html/*
+ dodoc -r doc/devel/*
+ fi
+ if use examples; then
+ docinto examples
+ dodoc -r examples/{production,clsync*}
+ fi
+}
diff --git a/app-doc/clsync-docs/clsync-docs-0.4.2.ebuild b/app-doc/clsync-docs/clsync-docs-0.4.2.ebuild
new file mode 100644
index 000000000000..104b181d2ef0
--- /dev/null
+++ b/app-doc/clsync-docs/clsync-docs-0.4.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN%-docs}"
+MY_P="${MY_PN}-${PV}"
+
+SRC_URI="https://github.com/xaionaro/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+KEYWORDS="~amd64 ~x86"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Clsync and libclsync API documentation"
+HOMEPAGE="http://ut.mephi.ru/oss/clsync https://github.com/xaionaro/clsync"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="api +examples"
+
+DEPEND="api? ( app-doc/doxygen )"
+
+src_configure() {
+ : # doxygen doesn't depend on configuration
+}
+
+src_compile() {
+ if use api; then
+ doxygen .doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ dodoc CONTRIB DEVELOPING NOTES PROTOCOL README.md SHORTHANDS TODO
+ if use api; then
+ dodoc -r doc/doxygen/html doc/devel/*
+ fi
+ if use examples; then
+ docinto examples
+ dodoc -r examples/{production,clsync*}
+ fi
+}
diff --git a/app-doc/clsync-docs/metadata.xml b/app-doc/clsync-docs/metadata.xml
new file mode 100644
index 000000000000..7d716daa96cb
--- /dev/null
+++ b/app-doc/clsync-docs/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>bircoph@gentoo.org</email>
+ <name>Andrew Savchenko</name>
+ </maintainer>
+ <longdescription>
+ Install documentation common for <pkg>app-admin/clsync</pkg> and
+ <pkg>dev-libs/libclsync</pkg> packages.
+</longdescription>
+ <use>
+ <flag name="api">Install doxygen generated API docs.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">xaionaro/clsync</remote-id>
+ </upstream>
+</pkgmetadata>