summaryrefslogtreecommitdiff
path: root/app-doc/cppman
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-doc/cppman
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-doc/cppman')
-rw-r--r--app-doc/cppman/Manifest4
-rw-r--r--app-doc/cppman/cppman-0.4.8-r2.ebuild (renamed from app-doc/cppman/cppman-0.4.8-r1.ebuild)20
-rw-r--r--app-doc/cppman/cppman-0.4.9.ebuild35
3 files changed, 50 insertions, 9 deletions
diff --git a/app-doc/cppman/Manifest b/app-doc/cppman/Manifest
index 49a0070f0170..8090382969c4 100644
--- a/app-doc/cppman/Manifest
+++ b/app-doc/cppman/Manifest
@@ -1,3 +1,5 @@
DIST cppman-0.4.8.tar.gz 3185978 BLAKE2B 9f662874eb6b6540e02a2b371fa47e53e0893239fbfcc65421fa5c7c4bc5f88c4cfd2facf08deb13606f5cf7c895a1a07e119e1c15bbc98b95af5f8056c6a5e8 SHA512 f5b93774988dad592b31670d6c21718bd034e4e94858982e1756e8db89779d12001fd786ba629211b038b173b7b507382277a3db7fb35363dba28cd029e69a7d
-EBUILD cppman-0.4.8-r1.ebuild 716 BLAKE2B 75e8f02f0e7588859660263f5964db0631640381452afca349a597413fcd5fa7f9ac48540c56aec9325932b45bb20f782d8739d8a1d3e24caded76af511b2313 SHA512 2e5ff03f14a255ed0a77bb34fade6916e05add25fe494be9854b57e8c938d18dc5be4cab06b5250a5aafad1aa7d754532da35df3f960f326c1635e0a2704c519
+DIST cppman-0.4.9.tar.gz 3237707 BLAKE2B 23068f8896dd4f9fa3ab86e8e3ddb7de5190af4f59f3cf283537c6ce8c3df60c5deab4972be750464121eeb1ebbde93e30c313869d5fb92e1d784d1294b1d842 SHA512 49957e9c9dcf82a85558d47325912e689ed7786f745015215b32e6f86b97878af6edcb265655674191992ba16171fdbf2220ee43d8c90a0d5eb37f1fb584c3ce
+EBUILD cppman-0.4.8-r2.ebuild 848 BLAKE2B 0dfc4d1b167e6e1ec3ed91302da8a679949bb2e95559d4e06b0d77c6493b55d2da8c43efbc107f3e0fd13f60bac55babcee8404a25f10cadb48afb2d516ca2ee SHA512 779a152208eecf5d1b372966e1180103d2a292852402be373863715cdf94f73a88521cd9a4ebb2fba3614ac0b7b2eb0412e7202118b5feed07c3e6bf670cef91
+EBUILD cppman-0.4.9.ebuild 848 BLAKE2B 0dfc4d1b167e6e1ec3ed91302da8a679949bb2e95559d4e06b0d77c6493b55d2da8c43efbc107f3e0fd13f60bac55babcee8404a25f10cadb48afb2d516ca2ee SHA512 779a152208eecf5d1b372966e1180103d2a292852402be373863715cdf94f73a88521cd9a4ebb2fba3614ac0b7b2eb0412e7202118b5feed07c3e6bf670cef91
MISC metadata.xml 247 BLAKE2B 8da6363de18a0eb4c29efee8c35de35970668cf0107b011b7e885c8d151b7cbd90709f000548025593f2ed5b4bc2d512de53c0285805fec978b363536ccf1ec4 SHA512 a788f5e022a740fafc174856c3fcda9b4c43908303427ecb48deb2198b5c01f1103bcf4965d950e3f981be4036173f9e968e431c49d3df96061f24cdc202edbc
diff --git a/app-doc/cppman/cppman-0.4.8-r1.ebuild b/app-doc/cppman/cppman-0.4.8-r2.ebuild
index 931aff72c2bd..6e35a51f7a2b 100644
--- a/app-doc/cppman/cppman-0.4.8-r1.ebuild
+++ b/app-doc/cppman/cppman-0.4.8-r2.ebuild
@@ -1,22 +1,22 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
-PYTHON_REQ_USE="sqlite,threads"
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite,threads(+)"
DISTUTILS_SINGLE_IMPL=true
+DISTUTILS_USE_SETUPTOOLS=no
inherit distutils-r1
DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
HOMEPAGE="https://github.com/aitjcize/cppman"
-LICENSE="GPL-3"
-
-SLOT="0"
SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
RDEPEND="
@@ -27,5 +27,9 @@ RDEPEND="
')
"
-# `./setup install` already installs docs
-DOCS=()
+src_prepare() {
+ default
+
+ # Don't allow setup.py to install documentation directly
+ sed -i '\:share/doc/cppman:d' setup.py || die "sed failed"
+}
diff --git a/app-doc/cppman/cppman-0.4.9.ebuild b/app-doc/cppman/cppman-0.4.9.ebuild
new file mode 100644
index 000000000000..6e35a51f7a2b
--- /dev/null
+++ b/app-doc/cppman/cppman-0.4.9.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite,threads(+)"
+
+DISTUTILS_SINGLE_IMPL=true
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="C++ man pages for Linux, with source from cplusplus.com and cppreference.com"
+HOMEPAGE="https://github.com/aitjcize/cppman"
+SRC_URI="https://github.com/aitjcize/cppman/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+
+RDEPEND="
+ sys-apps/groff
+ $(python_gen_cond_dep '
+ dev-python/beautifulsoup:4[${PYTHON_MULTI_USEDEP}]
+ dev-python/html5lib[${PYTHON_MULTI_USEDEP}]
+ ')
+"
+
+src_prepare() {
+ default
+
+ # Don't allow setup.py to install documentation directly
+ sed -i '\:share/doc/cppman:d' setup.py || die "sed failed"
+}