summaryrefslogtreecommitdiff
path: root/app-doc/doxygen/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-doc/doxygen/files
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-doc/doxygen/files')
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch13
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.4-gcc12-include.patch19
-rw-r--r--app-doc/doxygen/files/doxygen-1.9.4-link_with_pthread.patch24
3 files changed, 56 insertions, 0 deletions
diff --git a/app-doc/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch b/app-doc/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch
new file mode 100644
index 000000000000..f33f619e62ed
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.9.1-do_not_force_libcxx.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3775ed1..b3a1af6 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -23,7 +23,7 @@ option(build_doc "Build user manual (HTML and PDF)" OFF)
+ option(build_doc_chm "Build user manual (CHM)" OFF)
+ option(use_sqlite3 "Add support for sqlite3 output [experimental]." OFF)
+ if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
+- option(use_libc++ "Use libc++ as C++ standard library." ON)
++ option(use_libc++ "Use libc++ as C++ standard library." OFF)
+ endif()
+ option(use_libclang "Add support for libclang parsing." OFF)
+ option(static_libclang "Link to a statically compiled version of LLVM/libclang." OFF)
diff --git a/app-doc/doxygen/files/doxygen-1.9.4-gcc12-include.patch b/app-doc/doxygen/files/doxygen-1.9.4-gcc12-include.patch
new file mode 100644
index 000000000000..44505e4bed40
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.9.4-gcc12-include.patch
@@ -0,0 +1,19 @@
+https://github.com/doxygen/doxygen/commit/5198966c8d5fec89116d025c74934ac03ea511fa
+https://bugs.gentoo.org/844229
+
+From: Dimitri van Heesch <doxygen@gmail.com>
+Date: Fri, 6 May 2022 09:55:16 +0200
+Subject: [PATCH] issue #9312: Build: cache.h:53:14: error: 'exchange' is not a
+ member of 'std'
+
+--- a/src/cache.h
++++ b/src/cache.h
+@@ -19,6 +19,7 @@
+ #include <list>
+ #include <unordered_map>
+ #include <mutex>
++#include <utility>
+ #include <ctype.h>
+
+ /*! Fixed size cache for value type V using keys of type K.
+
diff --git a/app-doc/doxygen/files/doxygen-1.9.4-link_with_pthread.patch b/app-doc/doxygen/files/doxygen-1.9.4-link_with_pthread.patch
new file mode 100644
index 000000000000..66093eb7deb9
--- /dev/null
+++ b/app-doc/doxygen/files/doxygen-1.9.4-link_with_pthread.patch
@@ -0,0 +1,24 @@
+diff --git a/addon/doxywizard/.CMakeLists.txt.swp b/addon/doxywizard/.CMakeLists.txt.swp
+deleted file mode 100644
+index fc379d2..0000000
+Binary files a/addon/doxywizard/.CMakeLists.txt.swp and /dev/null differ
+diff --git a/addon/doxywizard/CMakeLists.txt b/addon/doxywizard/CMakeLists.txt
+index bb0e0eb..b6135bd 100644
+--- a/addon/doxywizard/CMakeLists.txt
++++ b/addon/doxywizard/CMakeLists.txt
+@@ -132,12 +132,12 @@ apply_editbin(doxywizard windows)
+ endif()
+
+ if(Qt5Core_FOUND)
+- target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml doxygen_version)
++ target_link_libraries(doxywizard Qt5::Core Qt5::Gui Qt5::Widgets Qt5::Xml doxygen_version pthread)
+ else()
+ if(Qt6Core_FOUND)
+- target_link_libraries(doxywizard Qt6::Core Qt6::Gui Qt6::Widgets Qt6::Xml doxygen_version)
++ target_link_libraries(doxywizard Qt6::Core Qt6::Gui Qt6::Widgets Qt6::Xml doxygen_version pthread)
+ else()
+- target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} doxygen_version)
++ target_link_libraries(doxywizard ${QT_LIBRARIES} ${QT_QTMAIN_LIBRARY} doxygen_version pthread)
+ endif()
+ endif()
+