summaryrefslogtreecommitdiff
path: root/app-doc/eclass-manpages/eclass-manpages-20200213.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /app-doc/eclass-manpages/eclass-manpages-20200213.ebuild
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'app-doc/eclass-manpages/eclass-manpages-20200213.ebuild')
-rw-r--r--app-doc/eclass-manpages/eclass-manpages-20200213.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/app-doc/eclass-manpages/eclass-manpages-20200213.ebuild b/app-doc/eclass-manpages/eclass-manpages-20200213.ebuild
new file mode 100644
index 000000000000..edcd2696352d
--- /dev/null
+++ b/app-doc/eclass-manpages/eclass-manpages-20200213.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="Collection of Gentoo eclass manpages"
+HOMEPAGE="https://github.com/mgorny/eclass-to-manpage"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# Keep the keywords stable. No need to change to ~arch.
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+
+BDEPEND="app-arch/xz-utils
+ sys-apps/gawk"
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+}