summaryrefslogtreecommitdiff
path: root/app-doc/eclass-manpages/eclass-manpages-20220925.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-25 11:33:33 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-25 11:33:33 +0100
commitd2e43b44e8855b7ee7b79782358dee45099efccc (patch)
treeb6dd4c6cf2a46f31df970692a4aed40056dff35e /app-doc/eclass-manpages/eclass-manpages-20220925.ebuild
parent1a256280f70812d1ae23f0ce2a2569291b6609da (diff)
gentoo auto-resync : 25:09:2022 - 11:33:33
Diffstat (limited to 'app-doc/eclass-manpages/eclass-manpages-20220925.ebuild')
-rw-r--r--app-doc/eclass-manpages/eclass-manpages-20220925.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-doc/eclass-manpages/eclass-manpages-20220925.ebuild b/app-doc/eclass-manpages/eclass-manpages-20220925.ebuild
new file mode 100644
index 000000000000..e4b5e442181a
--- /dev/null
+++ b/app-doc/eclass-manpages/eclass-manpages-20220925.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Instructions to make a dist tarball:
+# git clone https://github.com/mgorny/eclass-to-manpage.git
+# cd eclass-to-manpage
+# make dist ECLASSDIR=~/g/eclass/
+
+DESCRIPTION="Collection of Gentoo eclass manpages"
+HOMEPAGE="https://github.com/mgorny/eclass-to-manpage"
+SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+# Keep the keywords stable. No need to change to ~arch.
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-solaris"
+
+BDEPEND="sys-apps/gawk"
+
+src_install() {
+ emake install DESTDIR="${D}" PREFIX="${EPREFIX}/usr"
+}