summaryrefslogtreecommitdiff
path: root/app-doc/pms-bin/pms-bin-7_p20180430.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /app-doc/pms-bin/pms-bin-7_p20180430.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'app-doc/pms-bin/pms-bin-7_p20180430.ebuild')
-rw-r--r--app-doc/pms-bin/pms-bin-7_p20180430.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-doc/pms-bin/pms-bin-7_p20180430.ebuild b/app-doc/pms-bin/pms-bin-7_p20180430.ebuild
new file mode 100644
index 000000000000..cd22b28e239c
--- /dev/null
+++ b/app-doc/pms-bin/pms-bin-7_p20180430.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Gentoo Package Manager Specification"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Package_Manager_Specification"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/pms-${PV}-prebuilt.tar.xz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 ~riscv s390 sh sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris ~x86-winnt"
+IUSE="html"
+
+RDEPEND="!app-doc/pms"
+
+S="${WORKDIR}/pms-${PV}"
+
+src_install() {
+ dodoc pms.pdf eapi-cheatsheet.pdf
+ if use html; then
+ docinto html
+ dodoc *.html pms.css
+ dosym {..,/usr/share/doc/${PF}/html}/eapi-cheatsheet.pdf
+ fi
+}