summaryrefslogtreecommitdiff
path: root/app-editors/bluefish/bluefish-2.2.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /app-editors/bluefish/bluefish-2.2.12.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'app-editors/bluefish/bluefish-2.2.12.ebuild')
-rw-r--r--app-editors/bluefish/bluefish-2.2.12.ebuild29
1 files changed, 9 insertions, 20 deletions
diff --git a/app-editors/bluefish/bluefish-2.2.12.ebuild b/app-editors/bluefish/bluefish-2.2.12.ebuild
index 9b1dfeae212d..625cc993be5c 100644
--- a/app-editors/bluefish/bluefish-2.2.12.ebuild
+++ b/app-editors/bluefish/bluefish-2.2.12.ebuild
@@ -1,31 +1,27 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
PYTHON_COMPAT=( python3_{7..9} )
-inherit autotools python-single-r1 xdg
-
MY_P=${P/_/-}
+inherit autotools python-single-r1 xdg
DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer"
HOMEPAGE="http://bluefish.openoffice.nl/"
SRC_URI="https://www.bennewitz.com/bluefish/stable/source/${MY_P}.tar.bz2"
LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha amd64 ~ia64 ~ppc ~ppc64 ~sparc x86"
SLOT="0"
-IUSE="+gtk3 gucharmap nls python spell"
+IUSE="gucharmap nls python spell"
REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
RDEPEND="
sys-libs/zlib
- !gtk3? ( x11-libs/gtk+:2 )
- gtk3? (
- x11-libs/gtk+:3
- gucharmap? ( gnome-extra/gucharmap:2.90 )
- )
+ x11-libs/gtk+:3
+ gucharmap? ( gnome-extra/gucharmap:2.90 )
python? ( ${PYTHON_DEPS} )
spell? ( >=app-text/enchant-1.4:0 )"
DEPEND="${RDEPEND}
@@ -44,17 +40,10 @@ S="${WORKDIR}/${MY_P}"
RESTRICT="test"
pkg_setup() {
- if ! use gtk3 && use gucharmap ; then
- ewarn "gucharmap USE flag requires the gtk3 USE flag being enabled."
- ewarn "Disabling charmap plugin."
- fi
-
use python && python-single-r1_pkg_setup
}
-PATCHES=(
- "${FILESDIR}/${PN}-2.2.9-charmap_configure.patch"
-)
+PATCHES=( "${FILESDIR}/${PN}-2.2.9-charmap_configure.patch" )
# eautoreconf seems to no longer kill translation files.
src_prepare() {
@@ -68,8 +57,8 @@ src_configure() {
--disable-update-databases \
--disable-xml-catalog-update \
--with-freedesktop_org-appdata="${EPREFIX}"/usr/share/metainfo \
- $(use_with !gtk3 gtk2) \
- $(usex gtk3 "$(use_with gucharmap charmap)" '--without-charmap') \
+ --without-gtk2 \
+ $(use_with gucharmap charmap) \
$(use_enable nls) \
$(use_enable spell spell-check) \
$(use_enable python)