summaryrefslogtreecommitdiff
path: root/app-editors/bluefish/bluefish-2.2.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-16 16:47:37 +0100
commit8aebb228036d5e2863b7eaa6e319ab41c1669269 (patch)
tree00f4b90ce32462dc8e99ae54a31d6462ea2c3ac6 /app-editors/bluefish/bluefish-2.2.9.ebuild
parent76cba73c47c8694e74377004634daca18f2d9c08 (diff)
gentoo resync : 16.04.2018
Diffstat (limited to 'app-editors/bluefish/bluefish-2.2.9.ebuild')
-rw-r--r--app-editors/bluefish/bluefish-2.2.9.ebuild20
1 files changed, 13 insertions, 7 deletions
diff --git a/app-editors/bluefish/bluefish-2.2.9.ebuild b/app-editors/bluefish/bluefish-2.2.9.ebuild
index edf1fbd4866e..2e9a485511db 100644
--- a/app-editors/bluefish/bluefish-2.2.9.ebuild
+++ b/app-editors/bluefish/bluefish-2.2.9.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
PYTHON_COMPAT=( python2_7 )
-inherit autotools eutils fdo-mime python-single-r1
+inherit autotools gnome2-utils python-single-r1 xdg-utils
MY_P=${P/_/-}
@@ -77,12 +77,17 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
}
pkg_postinst() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
einfo "Adding XML catalog entries..."
/usr/bin/xmlcatalog --noout \
@@ -94,8 +99,9 @@ pkg_postinst() {
}
pkg_postrm() {
- fdo-mime_desktop_database_update
- fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
einfo "Removing XML catalog entries..."
/usr/bin/xmlcatalog --noout \
--del 'Bluefish/DTD/Bflang' \