summaryrefslogtreecommitdiff
path: root/app-editors/bluefish
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /app-editors/bluefish
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'app-editors/bluefish')
-rw-r--r--app-editors/bluefish/Manifest2
-rw-r--r--app-editors/bluefish/bluefish-2.2.12.ebuild103
2 files changed, 105 insertions, 0 deletions
diff --git a/app-editors/bluefish/Manifest b/app-editors/bluefish/Manifest
index aff840aff492..579c7b038c02 100644
--- a/app-editors/bluefish/Manifest
+++ b/app-editors/bluefish/Manifest
@@ -1,4 +1,6 @@
AUX bluefish-2.2.9-charmap_configure.patch 728 BLAKE2B fc7231ab28c0d0c4480e48f965d26ee18ae5819e412488ab8a5e30e3cee6925b73daa72fa178cdf204e00d1074121ddc57fd4c5795ccc6335460409a245bca5c SHA512 46482a73b6d374cdd5881e9ed7a79199c85cb436cc700950c09541a94d61fc4f200613a34575e74d013409f0e42a7c1df4ed25ed65880f25cbebd926d47c6889
DIST bluefish-2.2.10.tar.bz2 4159964 BLAKE2B 94210df4f9cf0abb46fa26612e1b64550f5970c72584b683779f5bcaf921a8925c6275c647125f73990e99a0175e3c92c0cc286590fbd08e938c6fd1d8c32cef SHA512 ddfad4c595d371dfd7ca5551c1771c2d82dbffcc90acda31bbd2a048730e24e2d1e37fbe847e5005d96acefdf5f38cb93785d23817e59624ecd7ea10bfbc3aeb
+DIST bluefish-2.2.12.tar.bz2 4180228 BLAKE2B 9e05a4618c37951da6a669e9bd4e0dd7e9993ea764dd467f875039b28cdc6d71ae70d1a87df7f0c63f850ebbff6ceeb8550d1d036bab32b7435f362d5b137147 SHA512 f0eb6496d371db8a9b4aee33ddf67e5e87bcc86ff283704cac115be7f00609b1ccbd47ff2d8f8b0bc30f234a339069cc1f7cb1f8809d97f94f0b0e09e4f16754
EBUILD bluefish-2.2.10.ebuild 2556 BLAKE2B 910fea9618911f35362e3162fb4c16e1eea08c954898500bf30256b49c194513aef6185b506d91fa1996b795d9dbfc96a4b14411ab677c364c4bf3bf176a6598 SHA512 e84bd7bc879ec41696fceb944a525d8d6b7ffbe0a339f1c6da3c20cd96bbfa551a832800095d794a4c0837aeeb359371db6d7698de01130459be375dd855eb04
+EBUILD bluefish-2.2.12.ebuild 2621 BLAKE2B b966f08b414d5ff14b122bfb523148eac36a2fd013a4a410d36b732c3b1f432e00d6b03774b2e40036faaff94154495d813dccf52a9012eb43274d5e9d608651 SHA512 50b04c1ed5b327949ab31fe2663ecc57d6f01fd2ab766086169466f0a49f25a25f07ae2584d060442485ba60f00939937feba59454fd469b0c6da5da506bf137
MISC metadata.xml 386 BLAKE2B d8663af89654394ea695c309c2ebbf2d3beba02463b2e57a0f91d7699af0e6457fa0ef0aa238f76359d3531bf4831475978fdd8ab4eb943dccc295e294b2eb4d SHA512 589c6c5db0ad2b93d2b44284faa19845b48e790252ecf5983fb3ba2c2b749894a382eea6dffe053413c0b29b86063a8906b88ae6f165b1cc9fc79742ae2fc188
diff --git a/app-editors/bluefish/bluefish-2.2.12.ebuild b/app-editors/bluefish/bluefish-2.2.12.ebuild
new file mode 100644
index 000000000000..9b1dfeae212d
--- /dev/null
+++ b/app-editors/bluefish/bluefish-2.2.12.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit autotools python-single-r1 xdg
+
+MY_P=${P/_/-}
+
+DESCRIPTION="A GTK HTML editor for the experienced web designer or programmer"
+HOMEPAGE="http://bluefish.openoffice.nl/"
+SRC_URI="https://www.bennewitz.com/bluefish/stable/source/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+SLOT="0"
+IUSE="+gtk3 gucharmap nls python spell"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+RDEPEND="
+ sys-libs/zlib
+ !gtk3? ( x11-libs/gtk+:2 )
+ gtk3? (
+ x11-libs/gtk+:3
+ gucharmap? ( gnome-extra/gucharmap:2.90 )
+ )
+ python? ( ${PYTHON_DEPS} )
+ spell? ( >=app-text/enchant-1.4:0 )"
+DEPEND="${RDEPEND}
+ x11-libs/pango"
+BDEPEND=">=dev-libs/glib-2.24:2
+ dev-libs/libxml2:2
+ virtual/pkgconfig
+ nls? (
+ sys-devel/gettext
+ dev-util/intltool
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+# there actually is just some broken manpage checkup -> not bother
+RESTRICT="test"
+
+pkg_setup() {
+ if ! use gtk3 && use gucharmap ; then
+ ewarn "gucharmap USE flag requires the gtk3 USE flag being enabled."
+ ewarn "Disabling charmap plugin."
+ fi
+
+ use python && python-single-r1_pkg_setup
+}
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.2.9-charmap_configure.patch"
+)
+
+# eautoreconf seems to no longer kill translation files.
+src_prepare() {
+ default
+ eautoreconf
+ sed -i 's:gzip -n $< -c:gzip -n -c $<:' data/bflib/Makefile.* || die "Cannot fix makefile"
+}
+
+src_configure() {
+ econf \
+ --disable-update-databases \
+ --disable-xml-catalog-update \
+ --with-freedesktop_org-appdata="${EPREFIX}"/usr/share/metainfo \
+ $(use_with !gtk3 gtk2) \
+ $(usex gtk3 "$(use_with gucharmap charmap)" '--without-charmap') \
+ $(use_enable nls) \
+ $(use_enable spell spell-check) \
+ $(use_enable python)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ einfo "Adding XML catalog entries..."
+ /usr/bin/xmlcatalog --noout \
+ --add 'public' 'Bluefish/DTD/Bflang' 'bflang.dtd' \
+ --add 'system' 'http://bluefish.openoffice.nl/DTD/bflang.dtd' 'bflang.dtd' \
+ --add 'rewriteURI' 'http://bluefish.openoffice.nl/DTD' '/usr/share/xml/bluefish-unstable' \
+ /etc/xml/catalog \
+ || ewarn "Failed to add XML catalog entries."
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ einfo "Removing XML catalog entries..."
+ /usr/bin/xmlcatalog --noout \
+ --del 'Bluefish/DTD/Bflang' \
+ --del 'http://bluefish.openoffice.nl/DTD/bflang.dtd' \
+ --del 'http://bluefish.openoffice.nl/DTD' \
+ /etc/xml/catalog \
+ || ewarn "Failed to remove XML catalog entries."
+}