summaryrefslogtreecommitdiff
path: root/app-editors/dav/dav-0.8.5-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /app-editors/dav/dav-0.8.5-r2.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'app-editors/dav/dav-0.8.5-r2.ebuild')
-rw-r--r--app-editors/dav/dav-0.8.5-r2.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/app-editors/dav/dav-0.8.5-r2.ebuild b/app-editors/dav/dav-0.8.5-r2.ebuild
index b04dad5486e8..bab3b72d4bdf 100644
--- a/app-editors/dav/dav-0.8.5-r2.ebuild
+++ b/app-editors/dav/dav-0.8.5-r2.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
inherit toolchain-funcs
DESCRIPTION="A minimal console text editor"
HOMEPAGE="http://dav-text.sourceforge.net/"
-
# The maintainer does not keep sourceforge's mirrors up-to-date,
# so we point to the website's store of files.
SRC_URI="http://dav-text.sourceforge.net/files/${P}.tar.gz"
@@ -15,18 +15,20 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha amd64 ppc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+BDEPEND="virtual/pkgconfig"
RDEPEND="sys-libs/ncurses:0="
-DEPEND="
- ${RDEPEND}
- virtual/pkgconfig
-"
+DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${P}-asneeded.patch"
"${FILESDIR}/${P}-davrc-buffer-overflow.patch"
"${FILESDIR}/fix-Wformat-security-warnings.patch"
+ "${FILESDIR}/${PN}-0.8.5-fno-common.patch"
+ "${FILESDIR}/${PN}-0.8.5-makefile.patch"
)
+DOCS=( README )
+
# Makefile only
src_configure() { :; }
@@ -37,4 +39,7 @@ src_compile() {
LDFLAGS="${LDFLAGS} $( $(tc-getPKG_CONFIG) --libs ncurses)"
}
-DOCS=( README )
+src_install() {
+ default
+ docompress -x /usr/share/man/man1/dav.1.gz
+}