summaryrefslogtreecommitdiff
path: root/app-editors/emact/emact-2.58.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/emact/emact-2.58.0.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/emact/emact-2.58.0.ebuild')
-rw-r--r--app-editors/emact/emact-2.58.0.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-editors/emact/emact-2.58.0.ebuild b/app-editors/emact/emact-2.58.0.ebuild
new file mode 100644
index 000000000000..6e0ffca331b0
--- /dev/null
+++ b/app-editors/emact/emact-2.58.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="EmACT, a fork of Conroy's MicroEmacs"
+HOMEPAGE="http://www.eligis.com/emacs/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="X"
+
+RDEPEND="sys-libs/ncurses:0=
+ X? ( x11-libs/libX11 )"
+DEPEND="${RDEPEND}
+ X? ( x11-base/xorg-proto )"
+
+src_configure() {
+ econf $(use_with X x)
+}
+
+src_install() {
+ emake INSTALL="${ED%/}"/usr install
+ #dodoc README
+}