summaryrefslogtreecommitdiff
path: root/app-editors/featherpad/featherpad-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-09 22:34:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-09 22:34:14 +0100
commit3a77d78ca92715b58ddac074baa5b25c4baf9a9b (patch)
tree6dc147c4f02d9c37807f61c29d1fad916f967a94 /app-editors/featherpad/featherpad-1.4.1.ebuild
parent785047acce64d1217286105397cc6fe433c34cb3 (diff)
gentoo auto-resync : 09:09:2023 - 22:34:14
Diffstat (limited to 'app-editors/featherpad/featherpad-1.4.1.ebuild')
-rw-r--r--app-editors/featherpad/featherpad-1.4.1.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/app-editors/featherpad/featherpad-1.4.1.ebuild b/app-editors/featherpad/featherpad-1.4.1.ebuild
index 69a1e0841b09..f39d1be78c82 100644
--- a/app-editors/featherpad/featherpad-1.4.1.ebuild
+++ b/app-editors/featherpad/featherpad-1.4.1.ebuild
@@ -13,12 +13,11 @@ S="${WORKDIR}/FeatherPad-${PV}"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~riscv ~x86"
-IUSE="+qt5 qt6 +X"
-REQUIRED_USE="^^ ( qt5 qt6 )"
+IUSE="qt6 +X"
RDEPEND="
app-text/hunspell:=
- qt5? (
+ !qt6? (
dev-qt/qtcore:5
dev-qt/qtdbus:5
dev-qt/qtgui:5
@@ -37,14 +36,14 @@ DEPEND="${RDEPEND}
X? ( x11-base/xorg-proto )
"
BDEPEND="
- qt5? ( dev-qt/linguist-tools:5 )
+ !qt6? ( dev-qt/linguist-tools:5 )
qt6? ( dev-qt/qttools:6[linguist] )
"
src_configure() {
local mycmakeargs=(
-DWITHOUT_X11=$(usex !X)
- -DENABLE_QT5=$(usex qt5)
+ -DENABLE_QT5=$(usex !qt6)
)
cmake_src_configure
}