summaryrefslogtreecommitdiff
path: root/app-editors/gedit-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-05 18:09:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-05 18:09:32 +0000
commit8973f70e9a2ae4ea8a324e607ea1e8b96c7ff384 (patch)
treebbe587aee6b255e6cc44d4fd753d1cb9dbd1cfce /app-editors/gedit-plugins
parentf29a41111b3a606f5d95049b1ba92daabbc68cc0 (diff)
gentoo auto-resync : 05:01:2023 - 18:09:32
Diffstat (limited to 'app-editors/gedit-plugins')
-rw-r--r--app-editors/gedit-plugins/Manifest2
-rw-r--r--app-editors/gedit-plugins/gedit-plugins-44.0.ebuild105
2 files changed, 107 insertions, 0 deletions
diff --git a/app-editors/gedit-plugins/Manifest b/app-editors/gedit-plugins/Manifest
index df722a22db9f..1dd92c51e992 100644
--- a/app-editors/gedit-plugins/Manifest
+++ b/app-editors/gedit-plugins/Manifest
@@ -1,3 +1,5 @@
DIST gedit-plugins-43.1.tar.xz 913072 BLAKE2B ebfaa6311aac490c75339cf506a58ce60864925ebee8284d72cc4b42634696511d7060eca1b8988d574e1b17dc0e0d32cc934da3c29421339044a220ea5e854e SHA512 2aad05ce15e148121b8e0dcf59546061e448aac09f42c28cee7dfc0b3c16965716059cf147c6391f1c439ac04241e94384bf6ff8dfaa40303dfe80d8de1e2fbc
+DIST gedit-plugins-44.0.tar.xz 913176 BLAKE2B 325b70566ba32d6f10edf1681df6d31bf10329389331c9ef4a89671da1b538ff4faebd07c224d5309a113fbb28d40b777fc34c27b8ab1c894abdfeeb2d3683b6 SHA512 878fb3df8ab4e9a338b25da7a8c89c8d8c2dadb78095d2c620448423a2c506e7ab4ac27e823452f0c624ecab97766cc35385271d5889f58a5963b0e343bd63ae
EBUILD gedit-plugins-43.1.ebuild 2587 BLAKE2B b11a55b0bdc122ad21906a09e8e0e45424a6767eeef6fd7ba52e34703968a21a1a583178d7b0419f79e066f4ee944b4820fe57b2ed64bcf58d7a28e50ce92c31 SHA512 a278ef3a963bfd7d2a3b040e8bab110e97a42c909193b99429daa62685e0060a8f6a2b905914ca821a677aa01ccdc191528dba72e2e2aab2a8be0dedba57263e
+EBUILD gedit-plugins-44.0.ebuild 2589 BLAKE2B 09230b7815f03b507a433391077a52c4090d5d90ac2ba3624844790a5ad0c3e0a41dcd91df799a8d765c2f0c18d621fe69bfab0e3c9a27ee27a4f824fcb3c42e SHA512 8b9212844b03c1a585dfe0d4a8a6e2a4c1a34b8ec79c576595213c856fd5acd7a031272b42b6d0065670b7ceee0dea7d6cab38f730f4eb328aef0ebedbacdc74
MISC metadata.xml 596 BLAKE2B cf545e591c160fc584c5c2b1e3f5fa6a47922a958f981daa5c85f3f6c8f7eaed2a520d6265241998dfe211098f70c75a0fdfff033e55e892e5775b678ea9ef5b SHA512 0a3b9e748bc2d22ea16a694f8ebd6196d05e6652f552523bfe6fa60f1c69ab50110692cda7a59239c8f6946c06d3139a4225f1744e0dd40ccbdef3e8b396f692
diff --git a/app-editors/gedit-plugins/gedit-plugins-44.0.ebuild b/app-editors/gedit-plugins/gedit-plugins-44.0.ebuild
new file mode 100644
index 000000000000..167eb07b5d61
--- /dev/null
+++ b/app-editors/gedit-plugins/gedit-plugins-44.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="Collection of extra plugins for the gedit Text Editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit/ThirdPartyPlugins"
+
+LICENSE="GPL-2+"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+SLOT="0"
+
+IUSE="charmap git +python terminal vala"
+REQUIRED_USE="
+ charmap? ( python )
+ git? ( python )
+ python? ( ${PYTHON_REQUIRED_USE} )
+ terminal? ( python )
+"
+
+RDEPEND="
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=app-editors/gedit-44.0
+
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-4.0.2:4
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-editors/gedit[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ )
+ charmap? ( >=gnome-extra/gucharmap-3:2.90[introspection] )
+ git? ( >=dev-libs/libgit2-glib-0.0.6[python] )
+ terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
+" # vte-0.52+ for feed_child API compatibility
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ use vala && vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dplugin_bookmarks=true
+ $(meson_use python plugin_bracketcompletion)
+ $(meson_use charmap plugin_charmap)
+ $(meson_use python plugin_codecomment)
+ $(meson_use python plugin_colorpicker)
+ $(meson_use python plugin_colorschemer)
+ -Dplugin_drawspaces=true
+ $(meson_use git plugin_git)
+ $(meson_use python plugin_joinlines)
+ $(meson_use python plugin_multiedit)
+ $(meson_use python plugin_sessionsaver)
+ $(meson_use python plugin_smartspaces)
+ $(meson_use python plugin_synctex)
+ $(meson_use terminal plugin_terminal)
+ $(meson_use python plugin_textsize)
+ -Dplugin_wordcompletion=true
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}