summaryrefslogtreecommitdiff
path: root/app-editors/gedit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-05 18:09:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-05 18:09:32 +0000
commit8973f70e9a2ae4ea8a324e607ea1e8b96c7ff384 (patch)
treebbe587aee6b255e6cc44d4fd753d1cb9dbd1cfce /app-editors/gedit
parentf29a41111b3a606f5d95049b1ba92daabbc68cc0 (diff)
gentoo auto-resync : 05:01:2023 - 18:09:32
Diffstat (limited to 'app-editors/gedit')
-rw-r--r--app-editors/gedit/Manifest2
-rw-r--r--app-editors/gedit/gedit-44.1.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/app-editors/gedit/Manifest b/app-editors/gedit/Manifest
index d4d6b442b1d1..47e9dc406d28 100644
--- a/app-editors/gedit/Manifest
+++ b/app-editors/gedit/Manifest
@@ -1,3 +1,5 @@
DIST gedit-43.2.tar.xz 2724036 BLAKE2B 64039018c604874945cc6835bba14d80f969b0a860c0384d969af7fc81cdc4ade568539a80571440af605f14eaf33730140a48b48b92d1bdb652199770ca3411 SHA512 447f0da946ff7474637bb6b88f41eb53e5ba886c66e8b9f8c17e67d2f52e3eb115d905a850300f70488cfebcd6654a14ce8c57044760f4fdb3394cedf4e91f23
+DIST gedit-44.1.tar.xz 2735700 BLAKE2B 275a614993c4a38d52455eb22c435697a452069f62b4332b4df8b1b83daa18192fa2159162387996122144645069500d3d48826d05a4b4133df285af387a8f52 SHA512 7eb48c8020726e0648565abff6aca32ddf464bc651c2e2298402b9ee3ff8c6ba64d4becc6da3290ac8a4b58705a5f3e09b7958a6cebe357d701708c525d6e3df
EBUILD gedit-43.2.ebuild 1770 BLAKE2B c48e25944efb1d716db31d8b7340a08c1ba5ebb89aac5bfe458478f2114db5d11ef28262a3e899cb09a52342d9bd4c773988a1a0b560dbd275b2c5d3bcb013f5 SHA512 3473bf78bc6f154279893813448a185fa0646be36092642e09ff767be2792cb6a999e886c5751e776ccd82089d4e652a4c280d7609e3647e46f33787589762b5
+EBUILD gedit-44.1.ebuild 1773 BLAKE2B c65f8b0645b54501570dfe30818397eeeb2b7f595269ce186feec4e83dea647212d0ef0c09d4827f27e4c929eb5971456df15c97d0171436133af988ae626c00 SHA512 e723c24fd9a84a69a1848d01896fd86edc05189a0224f42aa74080787ddc6e7274925d09cdea8d2bcfacc409d990837597142141059d2dc1f380b67905d3ec69
MISC metadata.xml 346 BLAKE2B 59226b3220bd9b1770fad0f5acf3b1888a57a3496f9e0a6eb0eb09c12b7a5aa461961753dd8a5a6f01db1cdb97af5b28d6a8d1d632b60f499f86e0864e29264f SHA512 3e1d83ad67b85a681b85f8fece9d6c2c3eab2f2f726447230dc1f2399a21cba211d97e11d8c06d0d1b1803fafe67be4b32c04b39c5f8586a421c525624f6697d
diff --git a/app-editors/gedit/gedit-44.1.ebuild b/app-editors/gedit/gedit-44.1.ebuild
new file mode 100644
index 000000000000..a0ccacb2d2c6
--- /dev/null
+++ b/app-editors/gedit/gedit-44.1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit gnome.org gnome2-utils meson python-single-r1 vala xdg
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="+python gtk-doc"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.70:2
+ >=x11-libs/gtk+-3.22.0:3[introspection]
+ >=gui-libs/amtk-5.6:=
+ >=gui-libs/tepl-6.4:=
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=dev-libs/gobject-introspection-1.54:=
+ >=app-text/gspell-0.2.5:0=
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ ')
+ )
+
+ >=x11-libs/gtksourceview-4.0.2:4[introspection,vala]
+"
+RDEPEND="${DEPEND}
+ x11-themes/adwaita-icon-theme
+ gnome-base/gsettings-desktop-schemas
+ gnome-base/gvfs
+"
+BDEPEND="
+ $(vala_depend)
+ app-text/docbook-xml-dtd:4.1.2
+ dev-util/glib-utils
+ gtk-doc? ( >=dev-util/gtk-doc-1 )
+ dev-util/itstool
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc gtk_doc)
+ -Duser_documentation=true
+
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ if use python; then
+ python_optimize
+ python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+ fi
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}