summaryrefslogtreecommitdiff
path: root/app-editors/ghex/ghex-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /app-editors/ghex/ghex-9999.ebuild
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'app-editors/ghex/ghex-9999.ebuild')
-rw-r--r--app-editors/ghex/ghex-9999.ebuild32
1 files changed, 22 insertions, 10 deletions
diff --git a/app-editors/ghex/ghex-9999.ebuild b/app-editors/ghex/ghex-9999.ebuild
index 02e8fb9d1908..b9a8b8490096 100644
--- a/app-editors/ghex/ghex-9999.ebuild
+++ b/app-editors/ghex/ghex-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -13,30 +13,42 @@ if [[ ${PV} == 9999 ]]; then
EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
SRC_URI=""
else
- MY_PV="4.alpha.1"
- SRC_URI="https://gitlab.gnome.org/GNOME/${PN}/-/archive/${MY_PV}/${PN}-${MY_PV}.tar.gz"
KEYWORDS="~amd64 ~arm ~riscv ~x86 ~amd64-linux ~x86-linux"
- S="${WORKDIR}/${PN}-${MY_PV}"
fi
LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
SLOT="4"
RDEPEND="
- >=dev-libs/atk-1.0.0
- >=dev-libs/glib-2.31.10:2
- >=x11-libs/gtk+-3.3.8:3
- gui-libs/gtk:4
+ >=dev-libs/glib-2.66.0:2
+ >=gui-libs/gtk-4.0.0:4
+ dev-libs/gobject-introspection
+ !app-editors/ghex:2
"
DEPEND="${RDEPEND}"
BDEPEND="
- dev-libs/appstream-glib
- dev-libs/libxml2:2
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
dev-util/itstool
>=sys-devel/gettext-0.19.8
virtual/pkgconfig
"
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ )
+ meson_src_configure
+}
+
pkg_postinst() {
xdg_pkg_postinst
gnome2_schemas_update