summaryrefslogtreecommitdiff
path: root/app-editors/ghex
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-18 21:36:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-18 21:36:58 +0100
commitea4d97bae88695501ff5f5c646a57e2e0488e423 (patch)
treeafc4100ae641b360049e5bc3a2e1cc4c408641bb /app-editors/ghex
parenta2f7cdda45fadf1f967379421e8d808b1a503cd3 (diff)
gentoo auto-resync : 18:08:2023 - 21:36:58
Diffstat (limited to 'app-editors/ghex')
-rw-r--r--app-editors/ghex/Manifest2
-rw-r--r--app-editors/ghex/ghex-44.2.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/app-editors/ghex/Manifest b/app-editors/ghex/Manifest
index bc19cfe90c7f..bc8e3b6b9e76 100644
--- a/app-editors/ghex/Manifest
+++ b/app-editors/ghex/Manifest
@@ -1,4 +1,6 @@
DIST ghex-44.1.tar.xz 895780 BLAKE2B 553dc5002a3524ad4642d4f7693d7ee69a0c94bbc2976c1fae640d7d71eb84e145bd764c7acc946735b0b45235b6229a269c12ccb8566e591a83311c6d6177d5 SHA512 4239af382ed3bce0a932db875b1ccc8e1666cfc2827cd13b65afc8310de9107e3f106553dbde4c2663aaf6f0bbc906c51d9f8b61d9af661baf6cbb6b6e2be675
+DIST ghex-44.2.tar.xz 897944 BLAKE2B 0db001b90390f7747792ac89a5daaf9d38165b72dce77c3a2fd41914a4386001b9f15aaf4352a3b41a204a9104a5234a6ac50a3a7269e10a151c000d57228480 SHA512 a06876e06488bb25b17fbdf17ea73e57f563fe49a414c173d680a6bf4db9b66b40fce90ad67cfb73c62f25d88f436a58b7e0fd588c7a664faf78c5058524cabf
EBUILD ghex-44.1.ebuild 1288 BLAKE2B 8ac8757709fd252e869b4e04f37ca0a3d6246925013a619e9f7cd5f46e03a1aad265331a73ebb6f1154c6a93b95e394b32a9ae2b089e1ff459ad88d50142010e SHA512 5cd15208030c234af09403ca9172a041d29d806811ebd9922717987d045e23b3fab54eca11cb9dcb6b74ed7a7083bf5c4a7287e940fa437993c8ff162984c5d6
+EBUILD ghex-44.2.ebuild 1292 BLAKE2B 590d545410f8eb1b863116b393a029c94233e2a5c09e46e16935ced912807b4572d0cd93284b35fb9bc8d4906268a6241e3d3e8937006f9f4270119f52479cfc SHA512 acb3bbf7b9e7cf26ce4985cb8fc4cde8bf7cc123da0faaf1647bf3654b3a062ab9da41e9079441900856aafcd24e42247d1ec350d399a554e4a5fad75d6d1fb8
EBUILD ghex-9999.ebuild 1292 BLAKE2B d0d628849dd93185e7802174726c92211f999142fb2ee8359a9d22edaf522326de806e95d00b830a4b369afc3f80b1c647a3fa39f127590560e75ab812e13538 SHA512 ae01eb04a1458d233add7e73d9f9cd021b49ed5d96dcfddddf860610d0003a7cb8b9ca2a56828bac3d65f0fc847aee6add97b50f4862564eedcb64db553ac46c
MISC metadata.xml 345 BLAKE2B 4c2385371bb42d47643f2a9d48ee5ed675267f812467fa03f69151bcdbeb996602be0a3995f976b61e0c018c8d69e3dcd37392f5927bbe24942f11c23794bac4 SHA512 c3f3cc3f436137299082ccdcaa57221d1b3f490b34febfcd6ca586769b0a8c76ce11cc5b8be823c8c88b942effc0b68d9c078ba3a28594c41419830dff04fcad
diff --git a/app-editors/ghex/ghex-44.2.ebuild b/app-editors/ghex/ghex-44.2.ebuild
new file mode 100644
index 000000000000..7d5199d0588b
--- /dev/null
+++ b/app-editors/ghex/ghex-44.2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="GNOME hexadecimal editor"
+HOMEPAGE="https://wiki.gnome.org/Apps/Ghex"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.gnome.org/GNOME/ghex.git"
+ SRC_URI=""
+else
+ KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="GPL-2+ FDL-1.1+"
+IUSE="gtk-doc test"
+RESTRICT="!test? ( test )"
+SLOT="4"
+
+RDEPEND="
+ >=dev-libs/glib-2.68.0:2
+ >=gui-libs/gtk-4.4.0:4
+ gui-libs/libadwaita:1
+ dev-libs/gobject-introspection
+ !app-editors/ghex:2
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ gtk-doc? ( dev-util/gi-docgen )
+ test? (
+ dev-util/desktop-file-utils
+ dev-libs/appstream-glib
+ )
+ dev-util/gtk-update-icon-cache
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Ddocdir="${EPREFIX}"/usr/share/gtk-doc/
+ -Ddevelopment=false
+ -Dmmap-buffer-backend=true
+ -Ddirect-buffer-backend=true
+ -Dintrospection=enabled
+ $(meson_use gtk-doc gtk_doc)
+ -Dstatic-html-help=false
+ -Dvapi=false
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}