summaryrefslogtreecommitdiff
path: root/app-editors/ghostwriter/ghostwriter-24.12.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-08 00:11:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-08 00:11:30 +0000
commit8b3c41ecef8a1cdd270ce3aabcfdfb991839699c (patch)
treeece43c29d9163f887ef99c43aad6f2f568961231 /app-editors/ghostwriter/ghostwriter-24.12.2.ebuild
parent1b2360e7bab42e4045232887cb4f6c4a24ca3975 (diff)
gentoo auto-resync : 08:02:2025 - 00:11:30HEADmaster
Diffstat (limited to 'app-editors/ghostwriter/ghostwriter-24.12.2.ebuild')
-rw-r--r--app-editors/ghostwriter/ghostwriter-24.12.2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-editors/ghostwriter/ghostwriter-24.12.2.ebuild b/app-editors/ghostwriter/ghostwriter-24.12.2.ebuild
new file mode 100644
index 000000000000..eafb0008acb8
--- /dev/null
+++ b/app-editors/ghostwriter/ghostwriter-24.12.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_CATEGORY="office"
+ECM_HANDBOOK="optional"
+KFMIN=6.7.0
+QTMIN=6.7.2
+inherit ecm gear.kde.org
+
+DESCRIPTION="Cross-platform, aesthetic, distraction-free markdown editor"
+HOMEPAGE="https://ghostwriter.kde.org/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE=""
+
+RDEPEND="
+ app-text/hunspell:=
+ >=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
+ >=dev-qt/qtsvg-${QTMIN}:6
+ >=dev-qt/qtwebchannel-${QTMIN}:6
+ >=dev-qt/qtwebengine-${QTMIN}:6
+ >=kde-frameworks/kcoreaddons-${KFMIN}:6
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:6
+ >=kde-frameworks/kxmlgui-${KFMIN}:6
+ >=kde-frameworks/sonnet-${KFMIN}:6
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ >=dev-qt/qtbase-${QTMIN}:6[concurrent]
+"
+BDEPEND="
+ >=dev-qt/qttools-${QTMIN}:6[linguist]
+ virtual/pkgconfig
+"
+
+DOCS=( CHANGELOG.md README.md )