summaryrefslogtreecommitdiff
path: root/app-editors/gnome-text-editor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-14 18:19:08 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-14 18:19:08 +0000
commit9ecdcfa46d8257a208dac1edc65aea2ccf11a799 (patch)
treeb279d7ba5ed35fb11619b62e48c61254e46ed4a8 /app-editors/gnome-text-editor
parenta18f8581f716592db51c45679c46e319db13ca29 (diff)
gentoo auto-resync : 14:03:2023 - 18:19:08
Diffstat (limited to 'app-editors/gnome-text-editor')
-rw-r--r--app-editors/gnome-text-editor/Manifest2
-rw-r--r--app-editors/gnome-text-editor/gnome-text-editor-44_rc.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/app-editors/gnome-text-editor/Manifest b/app-editors/gnome-text-editor/Manifest
index 0b6227357178..cb2978557657 100644
--- a/app-editors/gnome-text-editor/Manifest
+++ b/app-editors/gnome-text-editor/Manifest
@@ -1,3 +1,5 @@
DIST gnome-text-editor-43.2.tar.xz 611536 BLAKE2B d2230dee0b858384af9c9138631262eca27c0d79d9fc9dbf0a19206e325691326c1a8f80dee5ee4ade6f023b2cf91f10425eb522beed72bc41768645ca8200bc SHA512 b5fd2b5605b6ded13f0bcb684e543f8cd5fae0ec28f713d5cb45e07e5e17115632595d83e2ecbb37b7fba2eec887c11da2ea8d17b842de75ce1c4e27a0f17187
+DIST gnome-text-editor-44.rc.tar.xz 608816 BLAKE2B 6712bb75d1a02c5544736fb9d4e9aba6a9fffff9c8ffc1f9ac89359e911184b27dd0d3716c54c8583aa13ab66ef9c2ca36dc374c2285b263df58bace6e6ecdc9 SHA512 d704b32f6c83493cf17ea4afa7720ebd346f3667e780a1ed01425b8246930c23f2e078c8bc62ca65e00598d316da71da8baf057f2e13977dfd4789005e2a0b73
EBUILD gnome-text-editor-43.2.ebuild 1021 BLAKE2B 9f309ea815c8b6ae0eaa04aac753e3b4b1de2910039ee12784c13d436ec608465201a50814dcb375fa8cf4544736ea6e79394eafcd680cf41d2abfebce79eb49 SHA512 7284ac5c1ab6f875c5a34e69826b2ab2bd9b75d22b0f17fdd512d3b3d8a5dce5055a8be142e334e6bd938c5ce57f9fecc4495d2d88fb65c6e6df62205bf3aad5
+EBUILD gnome-text-editor-44_rc.ebuild 1152 BLAKE2B ec8cc659966b74287b4b5aa48fd7697ed062f7a20cca8a0b2c0caa3df36be8da138f4c70be6e07aa0ab08897810a93baa48ac3f2ef9c07402ec6ae932fc5bbb9 SHA512 8ecabbb463a6975a9bcca56f343997b81f6c3d415dbe0cdb49558682d1cfddebfb1556bd0a1f24c06ab9bd6f76aa969a6bb52b05ec66d1a2cc9439c60a5bdd79
MISC metadata.xml 358 BLAKE2B 908c67ba226a7e65b72a1cbaea99350f05fe9f904644c99b9c4e1e0c81f795c1420a0ca9cba1d56f59fb1b841151ffcf7d088add9f36a0e88314f7f52da94fcf SHA512 5862fb965119f76e19ed997e53e651778458604f1f9b69a1ee04db8eac52bdb6352da84ecb92555b31d3b8c62aa544c57c6040ed358af3beddd35fe356744d85
diff --git a/app-editors/gnome-text-editor/gnome-text-editor-44_rc.ebuild b/app-editors/gnome-text-editor/gnome-text-editor-44_rc.ebuild
new file mode 100644
index 000000000000..37784cf3ef85
--- /dev/null
+++ b/app-editors/gnome-text-editor/gnome-text-editor-44_rc.ebuild
@@ -0,0 +1,60 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A simple text editor for the GNOME desktop"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/gnome-text-editor"
+S="${WORKDIR}/gnome-text-editor-${PV/_/.}"
+SRC_URI="https://download.gnome.org/sources/${PN}/44/${PN}-44.rc.tar.xz"
+S="${WORKDIR}/${PN}-44.rc"
+
+LICENSE="GPL-3+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="spell"
+
+KEYWORDS="~amd64 ~riscv"
+
+DEPEND="
+ >=dev-libs/glib-2.73.0:2
+ >=gui-libs/gtk-4.7:4
+ >=gui-libs/gtksourceview-5.5.0:5
+ >=gui-libs/libadwaita-1.2:1
+ app-text/editorconfig-core-c
+ x11-libs/cairo
+ dev-libs/icu
+ spell? (
+ >=app-text/enchant-2.2.0:2
+ dev-libs/icu:=
+ )
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.21
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature spell enchant)
+ -Dbugreport_url="https://bugs.gentoo.org"
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}