summaryrefslogtreecommitdiff
path: root/app-editors/gummi/gummi-0.8.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /app-editors/gummi/gummi-0.8.3.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'app-editors/gummi/gummi-0.8.3.ebuild')
-rw-r--r--app-editors/gummi/gummi-0.8.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-editors/gummi/gummi-0.8.3.ebuild b/app-editors/gummi/gummi-0.8.3.ebuild
new file mode 100644
index 000000000000..71b4d8dc5e59
--- /dev/null
+++ b/app-editors/gummi/gummi-0.8.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Simple LaTeX editor for GTK+ users"
+HOMEPAGE="https://github.com/alexandervdm/gummi"
+SRC_URI="https://github.com/alexandervdm/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ app-text/gtkspell:3
+ app-text/poppler[cairo]
+ dev-libs/glib:2
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ x11-libs/gtk+:3
+ x11-libs/gtksourceview:3.0
+ x11-libs/pango
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ elog "Gummi supports spell-checking through gtkspell. Support for"
+ elog "additional languages can be added by installing myspell-**-"
+ elog "packages for your language of choice."
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}