summaryrefslogtreecommitdiff
path: root/app-editors/hteditor/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /app-editors/hteditor/files
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'app-editors/hteditor/files')
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-AR.patch14
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-format-security.patch57
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch36
-rw-r--r--app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch32
4 files changed, 0 insertions, 139 deletions
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-AR.patch b/app-editors/hteditor/files/hteditor-2.1.0-AR.patch
deleted file mode 100644
index 60a0427a2125..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-AR.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-https://bugs.gentoo.org/722040
---- a/configure.ac
-+++ b/configure.ac
-@@ -104,8 +104,8 @@ AC_PROG_CPP
- AC_PROG_CXX
- AC_PROG_YACC
- AM_PROG_LEX
--AC_PATH_PROG(AR, ar)
--AC_PATH_PROG(AR, gar)
-+AC_CHECK_TOOL(AR, ar)
-+AC_CHECK_TOOL(AR, gar)
-
- if test "x$AR" = "x"; then
- AC_MSG_ERROR([*** 'ar' and 'gar' missing, please install one of them or fix your \$PATH ***])
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-format-security.patch b/app-editors/hteditor/files/hteditor-2.1.0-format-security.patch
deleted file mode 100644
index 408d1b9b1be3..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-format-security.patch
+++ /dev/null
@@ -1,57 +0,0 @@
-https://bugs.gentoo.org/521018
-
-From 5839355d67ff822593190473a41512ca19e4280a Mon Sep 17 00:00:00 2001
-From: Anton Gladky <gladk@debian.org>
-Date: Wed, 18 Feb 2015 21:20:39 +0100
-Subject: [PATCH] Fix "format not a string" compilation failure
-
-Compilation with the flag -Werror=format-security fails with
-the message:
-
-error: format not a string literal and no format arguments
-
-This patch solves the issue.
----
- asm/x86dis.cc | 6 +++---
- htpal.cc | 2 +-
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/asm/x86dis.cc b/asm/x86dis.cc
-index 0830d9c..bb9028f 100644
---- a/asm/x86dis.cc
-+++ b/asm/x86dis.cc
-@@ -1218,15 +1218,15 @@ void x86dis::str_op(char *opstr, int *opstrlen, x86dis_insn *insn, x86_insn_op *
- default: {assert(0);}
- }
- if (!insn->rexprefix) {
-- sprintf(opstr, x86_regs[j][op->reg]);
-+ sprintf(opstr, "%s", x86_regs[j][op->reg]);
- } else {
-- sprintf(opstr, x86_64regs[j][op->reg]);
-+ sprintf(opstr, "%s", x86_64regs[j][op->reg]);
- }
- break;
- }
- case X86_OPTYPE_SEG:
- if (x86_segs[op->seg]) {
-- sprintf(opstr, x86_segs[op->seg]);
-+ sprintf(opstr, "%s", x86_segs[op->seg]);
- }
- break;
- case X86_OPTYPE_CRX:
-diff --git a/htpal.cc b/htpal.cc
-index 03dea18..3d5f51e 100644
---- a/htpal.cc
-+++ b/htpal.cc
-@@ -307,7 +307,7 @@ void palette_entry::strvalue(char *buf32bytes)
- text = "normal";
- }
- p = tag_make_color(p, 32, VCP(fg, bg));
-- p += sprintf(p, text);
-+ p += sprintf(p, "%s", text);
- p = tag_make_default_color(p, 32);
- *p = 0;
- }
---
-2.16.2
-
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch b/app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch
deleted file mode 100644
index 3516efd2871b..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-gcc-10.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-Backport a subset of upstream c++11 fixes.
---- a/htmacho.cc
-+++ b/htmacho.cc
-@@ -146,7 +146,7 @@ void ht_macho::init(Bounds *b, File *f, format_viewer_if **ifs, ht_format_group
- break;
- case MACHO_CPU_TYPE_I386:
- switch (c->flavor) {
-- case -1:
-+ default:
- createHostStruct(&c->state, MACHO_I386_THREAD_STATE_struct, image_endianess);
- break;
- }
---- a/htmachohd.cc
-+++ b/htmachohd.cc
-@@ -313,7 +313,7 @@ static ht_view *htmachoheader_init(Bounds *b, File *file, ht_format_group *group
- switch (macho_shared->header.cputype) {
- case MACHO_CPU_TYPE_I386:
- switch (c->flavor) {
-- case -1:
-+ default:
- m->add_staticmask_ptable(macho_i386_thread_state, ofs+4*4/*4 32bit words in thread_header*/, isbigendian);
- break;
- }
---- a/io/types.h
-+++ b/io/types.h
-@@ -87,8 +87,8 @@ union htmsg_param {
- };
-
- struct htmsg {
-- int msg;
-- int type;
-+ unsigned int msg;
-+ unsigned int type;
- htmsg_param data1;
- htmsg_param data2;
- };
diff --git a/app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch b/app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch
deleted file mode 100644
index ebcc3c0aa43e..000000000000
--- a/app-editors/hteditor/files/hteditor-2.1.0-gcc-7.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-https://bugs.gentoo.org/show_bug.cgi?id=620732
-
-Fixes build failure on gcc-7:
-
- htapp.cc: In function 'uint isqr(uint)':
- htapp.cc:3026:18: error: call of overloaded 'abs(uint)' is ambiguous
- while (abs(a - b) > 1) {
- ^
-
-Picked upstream patch that fixes it:
-
-commit 3b62f2f7e49e024ec9d3c5ffc8ff9cd87a107af6
-Author: Sebastian Biallas <sb@biallas.net>
-Date: Sun Nov 13 15:25:26 2016 +0100
-
- use unsigned variables
-
-diff --git a/htapp.cc b/htapp.cc
-index 53d8725..03236e2 100644
---- a/htapp.cc
-+++ b/htapp.cc
-@@ -3021,8 +3021,8 @@ void do_modal_resize()
-
- static uint isqr(uint u)
- {
-- uint a = 2;
-- uint b = u/a;
-+ int a = 2;
-+ int b = u/a;
- while (abs(a - b) > 1) {
- a = (a+b)/2;
- b = u/a;