summaryrefslogtreecommitdiff
path: root/app-editors/hteditor/hteditor-2.1.1_pre20161206.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-editors/hteditor/hteditor-2.1.1_pre20161206.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-editors/hteditor/hteditor-2.1.1_pre20161206.ebuild')
-rw-r--r--app-editors/hteditor/hteditor-2.1.1_pre20161206.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/app-editors/hteditor/hteditor-2.1.1_pre20161206.ebuild b/app-editors/hteditor/hteditor-2.1.1_pre20161206.ebuild
new file mode 100644
index 000000000000..17e1639f8b24
--- /dev/null
+++ b/app-editors/hteditor/hteditor-2.1.1_pre20161206.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=${P/editor}
+
+DESCRIPTION="A file viewer, editor and analyzer for text, binary, and executable files"
+HOMEPAGE="http://hte.sourceforge.net/ https://github.com/sebastianbiallas/ht/"
+#SRC_URI="mirror://sourceforge/hte/${MY_P}.tar.bz2"
+# tarball is done as: 'make dist' and then rename to mention latest commt
+SRC_URI="https://dev.gentoo.org/~slyfox/distfiles/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc ~ppc64 x86"
+IUSE="X"
+
+RDEPEND="sys-libs/ncurses:0=
+ X? ( x11-libs/libX11 )
+ >=dev-libs/lzo-2"
+DEPEND="${RDEPEND}
+ virtual/yacc
+ sys-devel/flex"
+
+DOCS=( AUTHORS ChangeLog KNOWNBUGS README TODO )
+
+S=${WORKDIR}/${MY_P/_pre*}
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1.0-tinfo.patch
+ "${FILESDIR}"/${PN}-2.1.0-gcc-6-uchar.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable X x11-textmode) \
+ --enable-maintainermode
+}
+
+src_install() {
+ #For prefix
+ chmod u+x "${S}/install-sh"
+
+ local HTML_DOCS="doc/*.html"
+ doinfo doc/*.info
+
+ default
+}