summaryrefslogtreecommitdiff
path: root/app-editors/jed
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/jed
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/jed')
-rw-r--r--app-editors/jed/Manifest3
-rw-r--r--app-editors/jed/jed-0.99.19.ebuild61
-rw-r--r--app-editors/jed/metadata.xml15
3 files changed, 79 insertions, 0 deletions
diff --git a/app-editors/jed/Manifest b/app-editors/jed/Manifest
new file mode 100644
index 000000000000..5d1f3dd669de
--- /dev/null
+++ b/app-editors/jed/Manifest
@@ -0,0 +1,3 @@
+DIST jed-0.99-19.tar.bz2 884198 BLAKE2B c3d967e59b909a39d0f7fb49c8ce9aef70585ba433bc5c6bebf5db1b6b88de0c41b35059a242a38be91a97a5296a279bdc85ac30ec9d4ae221d94e50e41d8995 SHA512 db8a30284f9b8e3e2c5d1a600eeb7af29c9f943a5c23d7c74fce926e0b0252f54805e214670e7c9357ce0e6918ad67cba2769a523979bfbd285328f94fff747c
+EBUILD jed-0.99.19.ebuild 1135 BLAKE2B 31333f1321e4f07b5d37b3198f4f91c22c7578996723c288a2d0152cf31b8dcc2f7c4343bc9c902c47772bcce8f670c048b48ea4eaf7272afd79d3510ca98bf5 SHA512 1311e8b402ab97a696f6538543da6b313fd84d62fd0fb3000642e03205d693d867fcb076843e9edcf1cab139ebeeda898875b6c33e6304381a537fa800d5981f
+MISC metadata.xml 614 BLAKE2B 023aea459e74aa16cbfd069da28b6c2bc1b87e17be50f1f49e4f070ef8764a75f53b56b6d61a9741caf93ccc1b07cd34a523940754fc33cb6591bdf7f6f417cc SHA512 79f54c7d84965a95e575c4c38d5c9a2158de0a1c539ee32f5839312bed707c8d0df00f7733c3cedeee1cfb3ac10619ff60dc0441f7062535f0d7f79094f5443b
diff --git a/app-editors/jed/jed-0.99.19.ebuild b/app-editors/jed/jed-0.99.19.ebuild
new file mode 100644
index 000000000000..04e69c80056f
--- /dev/null
+++ b/app-editors/jed/jed-0.99.19.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit versionator
+
+MY_P=${PN}-$(replace_version_separator 2 '-')
+
+DESCRIPTION="Console S-Lang-based editor"
+HOMEPAGE="http://www.jedsoft.org/jed/"
+SRC_URI="ftp://space.mit.edu/pub/davis/jed/v${PV%.*}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ppc ppc64 sparc x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="X gpm xft"
+
+RDEPEND=">=sys-libs/slang-2
+ gpm? ( sys-libs/gpm )
+ X? (
+ x11-libs/libX11
+ xft? (
+ >=media-libs/freetype-2
+ x11-libs/libXft
+ )
+ )"
+DEPEND="${RDEPEND}
+ X? (
+ x11-libs/libXt
+ x11-base/xorg-proto
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ export JED_ROOT="${EPREFIX}"/usr/share/jed
+ econf \
+ $(use_enable gpm) \
+ $(use_enable xft)
+}
+
+src_compile() {
+ emake
+ use X && emake xjed
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install
+
+ dodoc changes.txt INSTALL{,.unx} README
+ doinfo info/jed*
+
+ insinto /etc
+ doins lib/jed.conf
+
+ # replace IDE mode with EMACS mode
+ sed -i \
+ -e 's/\(_Jed_Default_Emulation = \).*/\1"emacs";/' \
+ "${ED}"/etc/jed.conf || die
+}
diff --git a/app-editors/jed/metadata.xml b/app-editors/jed/metadata.xml
new file mode 100644
index 000000000000..a3f50195b266
--- /dev/null
+++ b/app-editors/jed/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>emacs@gentoo.org</email>
+ <name>Gentoo Emacs project</name>
+</maintainer>
+<longdescription>
+ Jed is a powerful editor, terminal and X11 interface. Color syntax
+ highlighting is one of its strong suits, along with emulation of GNU Emacs,
+ Wordstar, EDT and Brief. It also supports use of GPM on Linux consoles.
+ Jed has a multitude of programming modes and couples with the Slang library
+ for powerful extensions.
+</longdescription>
+</pkgmetadata>