summaryrefslogtreecommitdiff
path: root/app-editors/juffed/files/0.10-link-libjuff-against-libenca.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-editors/juffed/files/0.10-link-libjuff-against-libenca.patch
reinit the tree, so we can have metadata
Diffstat (limited to 'app-editors/juffed/files/0.10-link-libjuff-against-libenca.patch')
-rw-r--r--app-editors/juffed/files/0.10-link-libjuff-against-libenca.patch24
1 files changed, 24 insertions, 0 deletions
diff --git a/app-editors/juffed/files/0.10-link-libjuff-against-libenca.patch b/app-editors/juffed/files/0.10-link-libjuff-against-libenca.patch
new file mode 100644
index 000000000000..5bd3882309ae
--- /dev/null
+++ b/app-editors/juffed/files/0.10-link-libjuff-against-libenca.patch
@@ -0,0 +1,24 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ccad5d1..304c0aa 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -190,6 +190,9 @@ add_library ( ${JUFFLIB} SHARED
+ target_link_libraries ( ${JUFFLIB}
+ ${QT_LIBRARIES}
+ )
++if (ENCA_FOUND)
++ target_link_libraries( ${JUFFLIB} ${ENCA_LIBRARIES} )
++endif (ENCA_FOUND)
+
+ add_library ( ${QSCI_ENGINE} SHARED
+ ${juffed_qsci_SRCS}
+@@ -277,9 +280,6 @@ target_link_libraries ( ${JUFFED}
+ ${QT_LIBRARIES}
+ ${QT_QTNETWORK_LIBRARY}
+ )
+-if (ENCA_FOUND)
+- target_link_libraries( ${JUFFED} ${ENCA_LIBRARIES} )
+-endif (ENCA_FOUND)
+
+ if ( UNIX )
+ set(CMAKE_CXX_FLAGS "-Wall -Werror -Wextra")