summaryrefslogtreecommitdiff
path: root/app-editors/kakoune
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-17 00:55:45 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-17 00:55:45 +0000
commit0e33d150b98b9f2354c92788ef9dc739850b40f6 (patch)
tree5f173b7b9f7cf827f5538b70795e34bc7f1c2c95 /app-editors/kakoune
parent1e3939094253168dfdada63e645d674cad69260e (diff)
gentoo auto-resync : 17:11:2022 - 00:55:45
Diffstat (limited to 'app-editors/kakoune')
-rw-r--r--app-editors/kakoune/Manifest1
-rw-r--r--app-editors/kakoune/files/kakoune-2021.11.08-gcc12.patch58
2 files changed, 0 insertions, 59 deletions
diff --git a/app-editors/kakoune/Manifest b/app-editors/kakoune/Manifest
index 1e4bc5e631c1..095490986a92 100644
--- a/app-editors/kakoune/Manifest
+++ b/app-editors/kakoune/Manifest
@@ -1,4 +1,3 @@
-AUX kakoune-2021.11.08-gcc12.patch 1543 BLAKE2B 5ddac65c8143ea581e30df3f7d5685dc0319a683d1b64d4ab5c538a79d8ab404ee3ce82aaa8cab8b8f53c854d2727a8568c2616914ab14f46dd2aa9b4b9fec6c SHA512 4c09b60141dc47fedebe1040fee888bd594f964df08040b0edfa27448cd1219078e50618ba6c9538a48cd5acbd0d7ad08968c1649d2b97447bf4fb332df0181b
DIST kakoune-2022.10.31.tar.bz2 556473 BLAKE2B 36489de5e4fa4406a847f43bf0f966c082e5c4a97e3c31d04c61fb8c4137fed4b6d1ce96ac921a85dc03fe7b90d8de172b6720ac32846507a3d0c996fe01191c SHA512 9a02a1a6bbb0b71a579b0286b4dfb6359b856183862b3e17354d2685b8215fa24c196b570a21dfd627e3d5a5b91e20ce0b74caff19e5772ab911cc42677bf720
EBUILD kakoune-2022.10.31.ebuild 769 BLAKE2B a0ab51637696a5ee9c0bec3427766866b3e51274acada61ccf5f9d49fa183d59977decb242bdb262aa91378ce0b7dad634c8f180271f1bb77ec94c2db4dbe0ef SHA512 6675ff7a2549b54908cdb4a50d5fa4c97c92aaa738cb1e9f86f492e31074b3f3da17d37c3efca273804a049be8a974646bcb0f88eb0002dfc37f927f8f8319c0
MISC metadata.xml 512 BLAKE2B afa8631f092bca6c3307dcd610340b39e41da979781f0f1ac391e873ae063088599cfc96c99bc81cca0c1244905ced51e3736b1fc387d0d9fdb8233be2810427 SHA512 a7e4da11480bc3f8bd09253901d9528235ce9a4f00a418cd5f58c898244850cafe944d6a828e1b871a2d98faba179fd9f4ddab99695a6762a4a7a290f1311a2f
diff --git a/app-editors/kakoune/files/kakoune-2021.11.08-gcc12.patch b/app-editors/kakoune/files/kakoune-2021.11.08-gcc12.patch
deleted file mode 100644
index 7f1101cdbf49..000000000000
--- a/app-editors/kakoune/files/kakoune-2021.11.08-gcc12.patch
+++ /dev/null
@@ -1,58 +0,0 @@
-https://bugs.gentoo.org/840647
-https://github.com/mawww/kakoune/issues/4544
-https://github.com/mawww/kakoune/pull/4549
-https://github.com/mawww/kakoune/commit/d1ea2ffa600fd2a7b14e415b68ceedba3325c5db
-
-commit d1ea2ffa600fd2a7b14e415b68ceedba3325c5db
-Author: Tim Allen <screwtape@froup.com>
-Date: Sat Feb 12 21:35:33 2022 +1100
-
- Make Color::validate_alpha() a constexpr function.
-
- We call it from a constexpr constructor, so it needs to be constexpr itself.
-
- Fixes #4544.
-
-diff --git a/src/color.cc b/src/color.cc
-index b355b9cf..dfe2e955 100644
---- a/src/color.cc
-+++ b/src/color.cc
-@@ -34,13 +34,6 @@ bool is_color_name(StringView color)
- return contains(color_names, color);
- }
-
--void Color::validate_alpha()
--{
-- static_assert(RGB == 17);
-- if (a < RGB)
-- throw runtime_error("Colors alpha must be > 16");
--}
--
- Color str_to_color(StringView color)
- {
- auto it = find_if(color_names, [&](const char* c){ return color == c; });
-diff --git a/src/color.hh b/src/color.hh
-index 943678ed..85babd98 100644
---- a/src/color.hh
-+++ b/src/color.hh
-@@ -1,6 +1,7 @@
- #ifndef color_hh_INCLUDED
- #define color_hh_INCLUDED
-
-+#include "exception.hh"
- #include "hash.hh"
- #include "meta.hh"
- #include "assert.hh"
-@@ -55,7 +56,11 @@ struct Color
- }
-
- private:
-- void validate_alpha();
-+ constexpr void validate_alpha() {
-+ static_assert(RGB == 17);
-+ if (a < RGB)
-+ throw runtime_error("Colors alpha must be > 16");
-+ }
- };
-
- constexpr bool operator==(Color lhs, Color rhs)