summaryrefslogtreecommitdiff
path: root/app-editors/leo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-16 17:34:21 +0000
commit02e2208f46f4e2c00fb9743cbc47350bdd233bfa (patch)
tree132dd60828854db4f65f30f9230f43d9602507ff /app-editors/leo
parent8be70107efbb417f839292165ee39d07a062046f (diff)
gentoo resync : 16.01.2018
Diffstat (limited to 'app-editors/leo')
-rw-r--r--app-editors/leo/Manifest2
-rw-r--r--app-editors/leo/leo-5.6.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/app-editors/leo/Manifest b/app-editors/leo/Manifest
index 4070579b522d..ffdcd1305337 100644
--- a/app-editors/leo/Manifest
+++ b/app-editors/leo/Manifest
@@ -1,3 +1,5 @@
DIST Leo-5.1-final.zip 9028778 BLAKE2B 17dcec884acc552c8079a842bc645c3279e66e52e2f043a92867ce4f00491561753156c8e4a31b9b132d2546d44a79d2d9c0050dfc153e0f37f043c992d0cb74 SHA512 a8e1d42c0b7c8f6aa4465295515ef19965a03142997a1b65304fd72a2c541248b7dba66d7be295465fd6dbdd7fcd5c6e6542d222edb71ddcab093c0c360340b1
+DIST leo-5.6.tar.gz 9255687 BLAKE2B 46a9aa1d90a1663ece57731b3685def3bf050f2c398310aca9d24c07256d23e40a94e505c43bd90c6c5a58fda2021409d3e6510eddd5a1bc0533273c45495475 SHA512 c9f6583be4f6a76d781adccc4076782c6f136b1057796228a398cd31c92d61e1b7a86d151f36352c6b1f677bb3d298b6f347c9874e3782c645fdb6ee38747955
EBUILD leo-5.1.ebuild 752 BLAKE2B 3e332a29baad839b4d77e98696030bad380c6114cf434ee7b3ae1ec64e4105c206e44fb7e17d2fb27a6dc5ca634b5750d279bf0796bd76b15445cc1af754ccfc SHA512 18dfa9502681e7f206ec99e3a3c82e7b5b8b00e0b0a1f7b6a00a218db1458cf6944cda41dfa4dbc419b8208e123fd23ad07122fe755c7120d814876f68410110
+EBUILD leo-5.6.ebuild 816 BLAKE2B f3f952bb40e8d3bd36d3a6e7fa637618b02bd6e28dbfb01c70019113bad9562e0ab063335243ebfd84d26eba06e5001027989671ebffd564feb4f10ecab6392e SHA512 0a77b58defea7f4a00c8c3cad0376570da17511d2f18298d97159c524911a62669b1dc859d3c1370c1a4342436c615fa31db4fa4aec5e4212671d05e1f5a5a89
MISC metadata.xml 308 BLAKE2B 2c8d0a692156e40f0d67d490212ded6b82a67efb0450e6512db856cc108772745dbcc5fade6b866b85bf07b4416db3357d3c04f3287ef8958477e6008828a8a3 SHA512 cfa3bb11079aca56b6b381f365e655078a1f07738c3af9d6c7d10313ee0a6826c0f40cc70e8ff31be6bf033a5effc8a7d725bccda8f78341700df10717976c66
diff --git a/app-editors/leo/leo-5.6.ebuild b/app-editors/leo/leo-5.6.ebuild
new file mode 100644
index 000000000000..a0947693d106
--- /dev/null
+++ b/app-editors/leo/leo-5.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${PN}-editor-${PV}"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQUIRED_USE="tk"
+inherit distutils-r1
+
+DESCRIPTION="Leo: Literate Editor with Outlines"
+HOMEPAGE="https://github.com/leo-editor/leo-editor/"
+SRC_URI="https://github.com/leo-editor/leo-editor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ app-text/silvercity[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ cp leo/dist/setup.py leo/dist/leo-install.py . || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( leo/doc/html/. )
+ distutils-r1_python_install_all
+}