summaryrefslogtreecommitdiff
path: root/app-editors/leo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/leo
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/leo')
-rw-r--r--app-editors/leo/Manifest3
-rw-r--r--app-editors/leo/leo-5.6.ebuild36
-rw-r--r--app-editors/leo/metadata.xml9
3 files changed, 48 insertions, 0 deletions
diff --git a/app-editors/leo/Manifest b/app-editors/leo/Manifest
new file mode 100644
index 000000000000..9056608e27e5
--- /dev/null
+++ b/app-editors/leo/Manifest
@@ -0,0 +1,3 @@
+DIST leo-5.6.tar.gz 9255687 BLAKE2B 46a9aa1d90a1663ece57731b3685def3bf050f2c398310aca9d24c07256d23e40a94e505c43bd90c6c5a58fda2021409d3e6510eddd5a1bc0533273c45495475 SHA512 c9f6583be4f6a76d781adccc4076782c6f136b1057796228a398cd31c92d61e1b7a86d151f36352c6b1f677bb3d298b6f347c9874e3782c645fdb6ee38747955
+EBUILD leo-5.6.ebuild 814 BLAKE2B dd44ea7d558f405d76b6a2ff47f113c1c7b0599c40b075cf397975999ab5a3605a8afd93f063f2d17e912f315be2faa84a634e0c8106a60df476852d2b03549a SHA512 416fb44fae4634fd72a5f14ab2816275d68b3c178499159836044db84cfee6f704548f4588b475be8dce19d1b67174ec0fc55157183800a34ec75c728f23a833
+MISC metadata.xml 308 BLAKE2B 2c8d0a692156e40f0d67d490212ded6b82a67efb0450e6512db856cc108772745dbcc5fade6b866b85bf07b4416db3357d3c04f3287ef8958477e6008828a8a3 SHA512 cfa3bb11079aca56b6b381f365e655078a1f07738c3af9d6c7d10313ee0a6826c0f40cc70e8ff31be6bf033a5effc8a7d725bccda8f78341700df10717976c66
diff --git a/app-editors/leo/leo-5.6.ebuild b/app-editors/leo/leo-5.6.ebuild
new file mode 100644
index 000000000000..2ee3cdc76dc0
--- /dev/null
+++ b/app-editors/leo/leo-5.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="${PN}-editor-${PV}"
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQUIRED_USE="tk"
+inherit distutils-r1
+
+DESCRIPTION="Leo: Literate Editor with Outlines"
+HOMEPAGE="https://github.com/leo-editor/leo-editor/"
+SRC_URI="https://github.com/leo-editor/leo-editor/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+RDEPEND="
+ app-text/silvercity[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ cp leo/dist/setup.py leo/dist/leo-install.py . || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( leo/doc/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/app-editors/leo/metadata.xml b/app-editors/leo/metadata.xml
new file mode 100644
index 000000000000..4e9fe29019ce
--- /dev/null
+++ b/app-editors/leo/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <!-- maintainer-needed -->
+ <upstream>
+ <remote-id type="github">leo-editor/leo-editor</remote-id>
+ <remote-id type="sourceforge">leo</remote-id>
+ </upstream>
+</pkgmetadata>