summaryrefslogtreecommitdiff
path: root/app-editors/levee/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/levee/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/levee/files')
-rw-r--r--app-editors/levee/files/levee-3.4o-darwin.patch16
-rw-r--r--app-editors/levee/files/levee-3.5-glibc210.patch80
-rw-r--r--app-editors/levee/files/levee-3.5a-QA.patch16
3 files changed, 112 insertions, 0 deletions
diff --git a/app-editors/levee/files/levee-3.4o-darwin.patch b/app-editors/levee/files/levee-3.4o-darwin.patch
new file mode 100644
index 000000000000..9481b1a3ade9
--- /dev/null
+++ b/app-editors/levee/files/levee-3.4o-darwin.patch
@@ -0,0 +1,16 @@
+--- unixcall.c.orig 2007-03-18 17:46:05 +0100
++++ unixcall.c 2007-03-18 17:51:13 +0100
+@@ -77,6 +77,13 @@
+ static int ioset = 0;
+ static struct termios old;
+
++#if defined(__MACH__)
++# define TCGETS TIOCGETA
++# define TCSETS TIOCSETA
++# define TCGETA TIOCGETA
++# define TCSETAF TIOCSETAF
++#endif
++
+ void
+ initcon()
+ {
diff --git a/app-editors/levee/files/levee-3.5-glibc210.patch b/app-editors/levee/files/levee-3.5-glibc210.patch
new file mode 100644
index 000000000000..51cc829cda25
--- /dev/null
+++ b/app-editors/levee/files/levee-3.5-glibc210.patch
@@ -0,0 +1,80 @@
+diff -NrU5 levee-3.5.original/editcor.c levee-3.5/editcor.c
+--- levee-3.5.original/editcor.c 2009-07-21 22:58:18.000000000 +0000
++++ levee-3.5/editcor.c 2009-07-21 23:07:21.000000000 +0000
+@@ -183,11 +183,11 @@
+
+ strcpy(scratch, "/tmp/lv.XXXXXX");
+
+ clrprompt();
+ printch('!');
+- if ( !getline(instring) )
++ if ( !get_line(instring) )
+ return FALSE;
+
+ if ( (tf = mkstemp(scratch)) < 0 ) {
+ prints("[tempfile error]");
+ return FALSE;
+diff -NrU5 levee-3.5.original/extern.h levee-3.5/extern.h
+--- levee-3.5.original/extern.h 2009-07-21 22:58:18.000000000 +0000
++++ levee-3.5/extern.h 2009-07-21 23:02:39.000000000 +0000
+@@ -195,11 +195,11 @@
+ extern exec_type PROC editcore();
+
+ extern char PROC line(), peekc(), readchar();
+ extern char PROC *findparse(),*makepat();
+
+-extern bool PROC getline();
++extern bool PROC get_line();
+ extern bool PROC putfile();
+ extern bool PROC doyank(), deletion(), putback();
+ extern bool PROC pushb(),pushi(),pushmem(),uputcmd(), delete_to_undo();
+ extern bool PROC ok_to_scroll(), move_to_undo();
+
+diff -NrU5 levee-3.5.original/main.c levee-3.5/main.c
+--- levee-3.5.original/main.c 2009-07-21 22:58:18.000000000 +0000
++++ levee-3.5/main.c 2009-07-21 23:09:52.000000000 +0000
+@@ -251,11 +251,11 @@
+ println();
+
+ mode=emode;
+ do {
+ prompt(FALSE,":");
+- if (getline(instring))
++ if (get_line(instring))
+ exec(instring, &mode, &noquit);
+ indirect = FALSE;
+ if (mode == E_VISUAL && zotscreen && noquit) { /*ask for more*/
+ prints(" [more]");
+ if ((ch=peekc()) == 13 || ch == ' ' || ch == ':')
+diff -NrU5 levee-3.5.original/misc.c levee-3.5/misc.c
+--- levee-3.5.original/misc.c 2009-07-21 22:58:18.000000000 +0000
++++ levee-3.5/misc.c 2009-07-21 23:09:10.000000000 +0000
+@@ -19,11 +19,11 @@
+ */
+ #include "levee.h"
+ #include "extern.h"
+
+ bool PROC
+-getline(str)
++get_line(str)
+ char *str;
+ {
+ int len;
+ char flag;
+
+diff -NrU5 levee-3.5.original/move.c levee-3.5/move.c
+--- levee-3.5.original/move.c 2009-07-21 22:58:18.000000000 +0000
++++ levee-3.5/move.c 2009-07-21 23:10:26.000000000 +0000
+@@ -158,11 +158,11 @@
+ case FSEARCH:
+ case BSEARCH:
+ clrprompt();
+ if (cmd == PATT_FWD || cmd == PATT_BACK) {
+ printch(tsearch = instring[0] = chars[cmd-PATT_FWD]);
+- if (!getline(&instring[1]))
++ if (!get_line(&instring[1]))
+ return ESCAPED; /* needs to skip later tests */
+ }
+ else {
+ if (!lsearch)
+ return BADMOVE;
diff --git a/app-editors/levee/files/levee-3.5a-QA.patch b/app-editors/levee/files/levee-3.5a-QA.patch
new file mode 100644
index 000000000000..7e37c76b34ac
--- /dev/null
+++ b/app-editors/levee/files/levee-3.5a-QA.patch
@@ -0,0 +1,16 @@
+diff -NrU5 levee-3.5a.original/configure.inc levee-3.5a/configure.inc
+--- levee-3.5a.original/configure.inc 2009-08-12 19:51:26.000000000 +0000
++++ levee-3.5a/configure.inc 2009-08-12 20:13:41.000000000 +0000
+@@ -1074,11 +1074,11 @@
+ else
+ PROG_INSTALL="$DEST"
+ fi
+
+ AC_SUB 'INSTALL' "$PROG_INSTALL"
+- AC_SUB 'INSTALL_PROGRAM' "$PROG_INSTALL -s -m 755"
++ AC_SUB 'INSTALL_PROGRAM' "$PROG_INSTALL -m 755"
+ AC_SUB 'INSTALL_DATA' "$PROG_INSTALL -m 444"
+
+ # finally build a little directory installer
+ # if mkdir -p works, use that, otherwise use install -d,
+ # otherwise build a script to do it by hand.