summaryrefslogtreecommitdiff
path: root/app-editors/mg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/mg
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/mg')
-rw-r--r--app-editors/mg/Manifest5
-rw-r--r--app-editors/mg/metadata.xml12
-rw-r--r--app-editors/mg/mg-20171014.ebuild47
-rw-r--r--app-editors/mg/mg-20180408.ebuild46
4 files changed, 110 insertions, 0 deletions
diff --git a/app-editors/mg/Manifest b/app-editors/mg/Manifest
new file mode 100644
index 000000000000..67a705cfb541
--- /dev/null
+++ b/app-editors/mg/Manifest
@@ -0,0 +1,5 @@
+DIST mg-20171014.tar.gz 141045 BLAKE2B a5b3bda6ff3b6416093069b471762687c2279737aa05b297ccd3077aff195cf52831566768613a81dcc977a27ac5ffd6e8a1874aa1010b6d90f4c678b6825cee SHA512 d55818308421aa523fb30b6e4725bb122f37637a822fabafeba9f9da3b97fd7f6af6431fce3015c969d0e656a48e89ed49b790deefc69fbdbb7e257f8a1aeb56
+DIST mg-20180408.tar.gz 141988 BLAKE2B db7da46fb0160acf8695f05234ed0c8e9a45e4239dc3abd433ddfb8b66e2b1aa550ffc4b409486a8990881d791ed73269a8ab78f6846cd4f0bee67761c11d281 SHA512 25fceb18fcbe63010e7a2e107aa5c30356938be2e04ff48869a12b5018dbb83bcf4dc70b03674713516616037247952a51454a28ca418cdc7b020d1f415f8701
+EBUILD mg-20171014.ebuild 1047 BLAKE2B ee8886aaabefaeb4005d711eb0520c4508407ff0d44c1b1a0094b025764242c9ff35df8808288b7b9df3a48120d0f00de880b454d1fb7176c0c570e5a3781e07 SHA512 e2f54dbdccc36ed6055b96c69246507c085fd88bb5bd136a05e8d2c364c0c887dc866405116fe1f28d63a03392c82da2abb2bee34db1075490cb3cbce24e92b0
+EBUILD mg-20180408.ebuild 1067 BLAKE2B 3ed53a0b87ea634bf765910a35f1b00005734f98d6bb0b8bc2579281de1fbf6cfed29d72a964e521e1b1c94d63b19030d474c6eb1468e62957043e25a5ad3a9a SHA512 d7757132baf374b65f3e6dce63dafc5183bd65518d72a53a06d8a401835de59b719c9f0c2c5ad0d7701c4567929eb526f623104516d7ee79cbea77918fce7504
+MISC metadata.xml 384 BLAKE2B 86ad99174028addfaef8bb9f143949161c8d1d81f2e946b3aa9088bd644b61ce97869d0a0b669abcff56e925fe8757d77f6123a2dfe340b8620db2ae84ba0b55 SHA512 70e2db47bef37d81a3842797ea0e12081e697b6e06bd25fbecfb64acf58b80e60a0c31508bf1c93879734af0921a47654fd489f08301b2517757741e0c6d25cf
diff --git a/app-editors/mg/metadata.xml b/app-editors/mg/metadata.xml
new file mode 100644
index 000000000000..00486d5abd44
--- /dev/null
+++ b/app-editors/mg/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>emacs@gentoo.org</email>
+ <name>Gentoo Emacs project</name>
+</maintainer>
+<longdescription>
+ mg is Micro GNU/emacs, this is a portable version of the mg maintained by
+ the OpenBSD team.
+</longdescription>
+</pkgmetadata>
diff --git a/app-editors/mg/mg-20171014.ebuild b/app-editors/mg/mg-20171014.ebuild
new file mode 100644
index 000000000000..232a6b42a429
--- /dev/null
+++ b/app-editors/mg/mg-20171014.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
+HOMEPAGE="https://homepage.boetes.org/software/mg/"
+SRC_URI="https://homepage.boetes.org/software/mg/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ppc ~ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="livecd"
+
+RDEPEND="sys-libs/ncurses:0
+ !elibc_FreeBSD? ( >=dev-libs/libbsd-0.7.0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # fix path to tutorial in man page
+ sed -i -e "s:doc/mg/:doc/${PF}/:" mg.1 || die
+
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ dobin mg
+ doman mg.1
+ dodoc README tutorial
+ # don't compress the tutorial, otherwise mg cannot open it
+ docompress -x /usr/share/doc/${PF}/tutorial
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
+ fi
+}
diff --git a/app-editors/mg/mg-20180408.ebuild b/app-editors/mg/mg-20180408.ebuild
new file mode 100644
index 000000000000..a7eea4e9015c
--- /dev/null
+++ b/app-editors/mg/mg-20180408.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="MicroGnuEmacs, a port from the BSDs"
+HOMEPAGE="https://homepage.boetes.org/software/mg/"
+SRC_URI="https://github.com/hboetes/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~hppa ~ppc ~ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd"
+IUSE="livecd"
+
+RDEPEND="sys-libs/ncurses:0
+ !elibc_FreeBSD? ( >=dev-libs/libbsd-0.7.0 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ # fix path to tutorial in man page
+ sed -i -e "s:doc/mg/:doc/${PF}/:" mg.1 || die
+ eapply_user
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" \
+ CFLAGS="${CFLAGS}" \
+ PKG_CONFIG="$(tc-getPKG_CONFIG)"
+}
+
+src_install() {
+ dobin mg
+ doman mg.1
+ dodoc README tutorial
+ # don't compress the tutorial, otherwise mg cannot open it
+ docompress -x /usr/share/doc/${PF}/tutorial
+}
+
+pkg_postinst() {
+ if use livecd; then
+ [[ -e ${EROOT}/usr/bin/emacs ]] || ln -s mg "${EROOT}"/usr/bin/emacs
+ fi
+}