summaryrefslogtreecommitdiff
path: root/app-editors/mousepad
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-13 21:59:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-13 21:59:42 +0100
commita0e652963f4d02b0e7c1148509f4ce3327c83808 (patch)
tree621db73bed25195d82efb6891ac2634295949450 /app-editors/mousepad
parent724570cf64d3eddb687d69ef236582cdd6363fb4 (diff)
gentoo auto-resync : 13:05:2023 - 21:59:42
Diffstat (limited to 'app-editors/mousepad')
-rw-r--r--app-editors/mousepad/Manifest4
-rw-r--r--app-editors/mousepad/metadata.xml3
-rw-r--r--app-editors/mousepad/mousepad-0.6.1.ebuild63
3 files changed, 69 insertions, 1 deletions
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
index 1e99db53bded..fa8e43bab2a7 100644
--- a/app-editors/mousepad/Manifest
+++ b/app-editors/mousepad/Manifest
@@ -1,3 +1,5 @@
DIST mousepad-0.6.0.tar.bz2 969433 BLAKE2B 690046e80f5cc74d928a8ea4d1ebcb513cf56dcaa3b295d5da528cbd139c36bc464a63a1c72acb833bcbb6f92c56b7f50f8222a3e2422d12b1f08188c12d75e0 SHA512 dad3488c973d767759a8b9752f83cc45d339064d34c19ee51f576af13f8db441f7234982c09e85f4032d553ee8df4f50ce8e0aa66c921a60ddb5c262a1c93702
+DIST mousepad-0.6.1.tar.bz2 1405279 BLAKE2B db94c433ba6dc697906258942abd0bcaa5a0a244c30c6e344e737944e84688045319551ebd1512aba541d87beafe5a8a26bb1265a06619aad64c7155140f33b3 SHA512 cf6ee9e32ecb1be9f1f54c587c4e8f653eb949f1103e378bf27959b88d8d6f268fb796285c8077bcef97926288cf941b9fb9426bfeb680ee728bddefa2d77d23
EBUILD mousepad-0.6.0.ebuild 992 BLAKE2B f6aa66dfc99dda03b970bbcb4697aa71bbaef52d02c2e02ea64879232a7038e8621f732098878a4e205dac0efc5c0c627e1f6b4f7a74b54087a89da1b2ef5414 SHA512 047ee99f743c89b58d6e84680024b9c6ab95b45c7c77141dadaf66a4a1a73f552dcfdb9ee7cf4036347b158c797467eb6a1e00dd68385a5b2787030259556382
-MISC metadata.xml 242 BLAKE2B e489d8bd8fc709502185e0439171cde4402146bc1ec7340bbe41550c06410a49faec8777cb7e79c3ba482feee774350beec5741ed8fe93a85ebed7b746f9200e SHA512 1bcfaf0482a1e7b5a7182d853dafaa2d47687bbc1c9d38b69ba35ce97cdeeff9bd2137a086c5af2a27b730a295e7cbd73d0b43fbe5af331bb7a3113d2117dff3
+EBUILD mousepad-0.6.1.ebuild 1247 BLAKE2B f435a815216cc56dec5fb9ae0d12179f373aa482d822cf95571400daf59b2dd7f8773c1fb88618007b08633e066bb2c0e4df5502d6d40836612479b8799dfc38 SHA512 0f00445725dac5a2d95344f91a905f481a3cf21efb29881c359357c342da625d7313eeb7c3dad6f1ba1c4d988fd3a7e9051e811215c2fd775b65e6e70eaf0a9d
+MISC metadata.xml 318 BLAKE2B 53e8d0080a2643b6d5191012a6c86316d926678a85190371ce498705fc142f83d1a325a935a75f8f29c19c878a677ba96a35d5e8702a23c4f1e7ec210dbeef3e SHA512 89a0b309c4a205b97627be6c0d3fb1a280d9c4dfd2107c09854ef6a912e38e0dc2da39e0768d5103b81b72bf84eed7b1014084c52ff9482f4acc13e8d1a3def3
diff --git a/app-editors/mousepad/metadata.xml b/app-editors/mousepad/metadata.xml
index fb3a6777ad9f..7ff48004695c 100644
--- a/app-editors/mousepad/metadata.xml
+++ b/app-editors/mousepad/metadata.xml
@@ -5,4 +5,7 @@
<email>xfce@gentoo.org</email>
<name>XFCE Team</name>
</maintainer>
+ <use>
+ <flag name="shortcuts">Build the "shortcuts" plugin</flag>
+ </use>
</pkgmetadata>
diff --git a/app-editors/mousepad/mousepad-0.6.1.ebuild b/app-editors/mousepad/mousepad-0.6.1.ebuild
new file mode 100644
index 000000000000..2098652637d9
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.6.1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/mousepad/start
+ https://gitlab.xfce.org/apps/mousepad/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+IUSE="policykit spell +shortcuts"
+
+DEPEND="
+ >=dev-libs/glib-2.56.2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-4.0.0:4
+ policykit? ( sys-auth/polkit )
+ spell? ( app-text/gspell )
+ shortcuts? ( >=xfce-base/libxfce4ui-4.17.5:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ --enable-gtksourceview4
+ $(use_enable policykit polkit)
+ $(use_enable spell plugin-gspell)
+ $(use_enable shortcuts plugin-shortcuts)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}