summaryrefslogtreecommitdiff
path: root/app-editors/mousepad
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-05 23:43:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-05 23:43:10 +0000
commitd82c6c919aa63b46ec1683492b75162951f09072 (patch)
tree559264efa71b0a426b715aee43022d8f5c714b06 /app-editors/mousepad
parentc31f575f39c1e387f18f630fb01d3a89c2339fdf (diff)
gentoo auto-resync : 05:02:2024 - 23:43:10
Diffstat (limited to 'app-editors/mousepad')
-rw-r--r--app-editors/mousepad/Manifest2
-rw-r--r--app-editors/mousepad/mousepad-0.6.2.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
index fc313ecfc701..39d7673ef708 100644
--- a/app-editors/mousepad/Manifest
+++ b/app-editors/mousepad/Manifest
@@ -1,3 +1,5 @@
DIST mousepad-0.6.1.tar.bz2 1405279 BLAKE2B db94c433ba6dc697906258942abd0bcaa5a0a244c30c6e344e737944e84688045319551ebd1512aba541d87beafe5a8a26bb1265a06619aad64c7155140f33b3 SHA512 cf6ee9e32ecb1be9f1f54c587c4e8f653eb949f1103e378bf27959b88d8d6f268fb796285c8077bcef97926288cf941b9fb9426bfeb680ee728bddefa2d77d23
+DIST mousepad-0.6.2.tar.bz2 1402314 BLAKE2B c783ec58317ca3c0eaa0023ade3043f4aa4f020a12c0258fe0cf1e2303aa07dfbc67b9aa0178ca9282da98754103fda6c90ba034fa4057dd855b400c0d371085 SHA512 086f60f6f405290ed76366f4c5195e9c8f9c5058d1892200a73e48d6378428efe47f2038e3eddb81186e22dd87d57580559a556b1b22f202b6f056c7f90b64ea
EBUILD mousepad-0.6.1.ebuild 1268 BLAKE2B f7f0492cd8acf41a453f26ad9d3eedaac04ce1a82ff96641a70553790683b534ecfef07d39a07eaffd392a3233d2308e582ccf0a5c918981c886c0549400e5f7 SHA512 8e6d54ce565f0e74cd64fbedd85b8b53506df45fdcc6fd88e1988a66cbabe37dd7916c558c5885c475140a5a1c7c01c192dd36d3aaefc80be5f18f1e8d22c69a
+EBUILD mousepad-0.6.2.ebuild 1272 BLAKE2B 705da414728941a40ad79d929661891f8cb614935a996bd93790111c4d30b7bd2df4e381c54a1692041da6bde993661cf8f1170ae44e264cb6a01608dce2fe20 SHA512 83c2e82dd6081f8c2f68e131071730dfb8a8e31691587df68eed40f7580287624413302ac89fb6127e56a759fad42661631ddd4602c2dedb0591755f4d196c48
MISC metadata.xml 318 BLAKE2B 53e8d0080a2643b6d5191012a6c86316d926678a85190371ce498705fc142f83d1a325a935a75f8f29c19c878a677ba96a35d5e8702a23c4f1e7ec210dbeef3e SHA512 89a0b309c4a205b97627be6c0d3fb1a280d9c4dfd2107c09854ef6a912e38e0dc2da39e0768d5103b81b72bf84eed7b1014084c52ff9482f4acc13e8d1a3def3
diff --git a/app-editors/mousepad/mousepad-0.6.2.ebuild b/app-editors/mousepad/mousepad-0.6.2.ebuild
new file mode 100644
index 000000000000..4d6ef31ee3be
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.6.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/mousepad/start
+ https://gitlab.xfce.org/apps/mousepad/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="policykit spell +shortcuts"
+
+DEPEND="
+ >=dev-libs/glib-2.56.2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-4.0.0:4
+ policykit? ( sys-auth/polkit )
+ spell? ( app-text/gspell )
+ shortcuts? ( >=xfce-base/libxfce4ui-4.17.5:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ --enable-gtksourceview4
+ $(use_enable policykit polkit)
+ $(use_enable spell plugin-gspell)
+ $(use_enable shortcuts plugin-shortcuts)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}