summaryrefslogtreecommitdiff
path: root/app-editors/mousepad
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /app-editors/mousepad
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'app-editors/mousepad')
-rw-r--r--app-editors/mousepad/Manifest2
-rw-r--r--app-editors/mousepad/mousepad-0.6.0.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/app-editors/mousepad/Manifest b/app-editors/mousepad/Manifest
index 30cca9670e22..2b60521781bb 100644
--- a/app-editors/mousepad/Manifest
+++ b/app-editors/mousepad/Manifest
@@ -1,3 +1,5 @@
DIST mousepad-0.5.10.tar.bz2 959696 BLAKE2B bd21145f23f1e92d67489a3ffcdca0afd977aa639706dece5aefd2f5417d2b2122accc1a5c727ec13a4c2f311ec479612953006d78b5509e836f360566d0d320 SHA512 144e72abce8e5fb66a345fb59efe48f136dd9cf9cdcd72496dcee05b08781bdbba036f4ab5af04dbccd38dc52a8e8dd67b5b7434867881a1114de692a012b076
+DIST mousepad-0.6.0.tar.bz2 969433 BLAKE2B 690046e80f5cc74d928a8ea4d1ebcb513cf56dcaa3b295d5da528cbd139c36bc464a63a1c72acb833bcbb6f92c56b7f50f8222a3e2422d12b1f08188c12d75e0 SHA512 dad3488c973d767759a8b9752f83cc45d339064d34c19ee51f576af13f8db441f7234982c09e85f4032d553ee8df4f50ce8e0aa66c921a60ddb5c262a1c93702
EBUILD mousepad-0.5.10.ebuild 990 BLAKE2B 9b497dfeb0898cb8e3b5f6d181fad7dfbf157bd0db010e62d4e5f9c2fccaa718ba03be8a49d920014a65eb9343c4813b42333a9945591ac2c344c632b8bb9c72 SHA512 ba1adda317e4ff03e37b633f142ba97855d2eca542bde1b100fa7d82b61c96ad94c8d9d90b6fb0154c5b0b6b6285d65d9180eed48da5f293bf2fc4e42ce2b819
+EBUILD mousepad-0.6.0.ebuild 994 BLAKE2B 2a89932a29398f2f3ff38025eb3faf1ce78962972bf151972760dd29424931505ed7aac505e0dc1e7fb0c741a4f2e600e63a95527b5e378497a064047addb831 SHA512 bf85da9aa6017c5cb7a6fe5b91eb9fcff2f6a915918323e4cc6560f388addc163c2f6fc99bca4a1212467b3459a43822dc391450a77a439565e7b48284ea9db2
MISC metadata.xml 242 BLAKE2B e489d8bd8fc709502185e0439171cde4402146bc1ec7340bbe41550c06410a49faec8777cb7e79c3ba482feee774350beec5741ed8fe93a85ebed7b746f9200e SHA512 1bcfaf0482a1e7b5a7182d853dafaa2d47687bbc1c9d38b69ba35ce97cdeeff9bd2137a086c5af2a27b730a295e7cbd73d0b43fbe5af331bb7a3113d2117dff3
diff --git a/app-editors/mousepad/mousepad-0.6.0.ebuild b/app-editors/mousepad/mousepad-0.6.0.ebuild
new file mode 100644
index 000000000000..7867506e677b
--- /dev/null
+++ b/app-editors/mousepad/mousepad-0.6.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="GTK+-based editor for the Xfce Desktop Environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/mousepad/start
+ https://gitlab.xfce.org/apps/mousepad/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-libs/glib-2.56.2
+ >=x11-libs/gtk+-3.22:3
+ >=x11-libs/gtksourceview-4.0.0:4
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ --enable-gtksourceview4
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}