summaryrefslogtreecommitdiff
path: root/app-editors/nano/nano-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /app-editors/nano/nano-9999.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'app-editors/nano/nano-9999.ebuild')
-rw-r--r--app-editors/nano/nano-9999.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/app-editors/nano/nano-9999.ebuild b/app-editors/nano/nano-9999.ebuild
index 25ad3e614940..c2da47a585b9 100644
--- a/app-editors/nano/nano-9999.ebuild
+++ b/app-editors/nano/nano-9999.ebuild
@@ -91,3 +91,13 @@ src_install() {
use split-usr && dosym ../../bin/nano /usr/bin/nano
}
+
+pkg_postrm() {
+ local e
+ [[ -n ${REPLACED_BY_VERSION} ]] && return
+ e=$(unset EDITOR; . "${EROOT}"/etc/profile &>/dev/null; echo "${EDITOR}")
+ if [[ ${e##*/} == nano ]]; then
+ ewarn "The EDITOR variable is still set to ${e}."
+ ewarn "You can update it with \"eselect editor\"."
+ fi
+}