summaryrefslogtreecommitdiff
path: root/app-editors/nano
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-16 00:53:50 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-16 00:53:50 +0000
commit84dcbb8bcdcf5785ac3b24905c73ae4aa6bb781e (patch)
tree6f6b979013e5661ca4b3690bc9417307fdc169ce /app-editors/nano
parent57e62db33bb33adb6593a2be7b3a5990aaf01f56 (diff)
gentoo auto-resync : 16:11:2022 - 00:53:49
Diffstat (limited to 'app-editors/nano')
-rw-r--r--app-editors/nano/Manifest2
-rw-r--r--app-editors/nano/nano-7.0.ebuild113
2 files changed, 115 insertions, 0 deletions
diff --git a/app-editors/nano/Manifest b/app-editors/nano/Manifest
index 23c210a27d6e..785392c7d082 100644
--- a/app-editors/nano/Manifest
+++ b/app-editors/nano/Manifest
@@ -1,5 +1,7 @@
AUX gentoo.nanorc-r1 5378 BLAKE2B 0d9a506a87ec75eab5cf04d94f65c3089f0cb442e705fbefc70b4a5b1d08fd360bfc136b6e1cdc4ed480f4ffb6b37b81a019869aa7e322b3f96219241a2d1569 SHA512 bc8db27b8509059833ce1939a3c63d8389968366118596f2a832e188ea5f3e8eb2b66e781ceaabd58c941bbb8ca6818b363189ac267a96f0943bbd64983b5c65
DIST nano-6.4.tar.xz 1593804 BLAKE2B b59ff7a741ce4c8b31afdbbfaf1d704cccbceddcd7f1421f30a6dd40495ec456ca891aeb9777c070c6cce4e9c594f83798ff0cdacdfe06e81b0aa0b700033da3 SHA512 cff2d9d90f1a23ab8905320e651f8bbc9d38046153a4f64bbc21927687d9628135915468b00b28f88a0eb7d395d1bcb0b9b7abcf367e5a46a5f3da01d8d6e72b
+DIST nano-7.0.tar.xz 1598528 BLAKE2B 5212aa2a65cc7bccb33ebd66934e53ea7c6bd739ceae94796397bd193698453417eae2a5cf63c995e90aa077795f9bcf70568a35208716a09c9a6d89d75ff409 SHA512 927db4dec1fcde316104a59ab208ffadea52a65c63888187794d4b47c5d49b591c39d490fdc31255b82f04d77a4321b2f6bb150022a5f88dd3c2500df327b983
EBUILD nano-6.4.ebuild 2703 BLAKE2B 77ce48f293a4c8200b3e8175bf07e8aa1158229887062324c8aafbdb96846c66bfe9ca5d8cf3889595c060dd13982cea0bfa42fc8b125075311e259f2d5a08be SHA512 786d9897c4ec70eac6d3107b9ce6fed248af4b76c450eab17df5ed37aa325faa73d7c764b5ac7aabb98b1d64c362aeb3624f7ff18468c322e584b33ad81c25e5
+EBUILD nano-7.0.ebuild 2711 BLAKE2B 006aeed5a9c878a74019dc9e3f64616292893900e7d30d43178266bced135393de234044453c775210318ea1a1c5f1c7be9e6c9c1294ff610e289c4df1eb1768 SHA512 4cc302df2531125f62f1e3ab4a41dde065268b544652d6607aeb4f01d01168bccc5ece0257e07e0be4842b137021ae3336a0c802c7fd8fb01e99f69de5ebb2a6
EBUILD nano-9999.ebuild 2711 BLAKE2B 006aeed5a9c878a74019dc9e3f64616292893900e7d30d43178266bced135393de234044453c775210318ea1a1c5f1c7be9e6c9c1294ff610e289c4df1eb1768 SHA512 4cc302df2531125f62f1e3ab4a41dde065268b544652d6607aeb4f01d01168bccc5ece0257e07e0be4842b137021ae3336a0c802c7fd8fb01e99f69de5ebb2a6
MISC metadata.xml 1677 BLAKE2B f6ed764002859bb082787004b858cc2098273fe034df9215ab380c90d2b6dcea168cd92b2fb6ea69ea157e9f9cb239e5499fb1dd8337d167c13031f8b5505343 SHA512 cf2a9a4224b47bc7657c2bfedacba1db7f66e8f1de25fa6203eb9fcd779bc646cc19ddfcc2b7f2555c8f1d8f173c87792db16667535cd053f1a21fc658ad518f
diff --git a/app-editors/nano/nano-7.0.ebuild b/app-editors/nano/nano-7.0.ebuild
new file mode 100644
index 000000000000..3ccb2377fa61
--- /dev/null
+++ b/app-editors/nano/nano-7.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://git.savannah.gnu.org/git/nano.git"
+ inherit autotools git-r3
+else
+ MY_P="${PN}-${PV/_}"
+ SRC_URI="https://www.nano-editor.org/dist/v${PV:0:1}/${MY_P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="GNU GPL'd Pico clone with more functionality"
+HOMEPAGE="https://www.nano-editor.org/ https://wiki.gentoo.org/wiki/Nano/Basics_Guide"
+
+LICENSE="GPL-3+ LGPL-2.1+ || ( GPL-3+ FDL-1.2+ )"
+SLOT="0"
+IUSE="debug justify magic minimal ncurses nls +spell +split-usr static unicode"
+
+LIB_DEPEND="
+ >=sys-libs/ncurses-5.9-r1:=[unicode(+)?]
+ sys-libs/ncurses:=[static-libs(+)]
+ magic? ( sys-apps/file[static-libs(+)] )
+ nls? ( virtual/libintl )
+"
+RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )"
+DEPEND="
+ ${RDEPEND}
+ static? ( ${LIB_DEPEND} )
+"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+"
+
+REQUIRED_USE="
+ magic? ( !minimal )
+"
+
+src_prepare() {
+ default
+
+ if [[ ${PV} == 9999 ]] ; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ use static && append-ldflags -static
+
+ local myconfargs=(
+ --bindir="${EPREFIX}"/bin
+ --htmldir=/trash
+ $(use_enable !minimal color)
+ $(use_enable !minimal multibuffer)
+ $(use_enable !minimal nanorc)
+ $(use_enable magic libmagic)
+ $(use_enable spell speller)
+ $(use_enable justify)
+ $(use_enable debug)
+ $(use_enable nls)
+ $(use_enable unicode utf8)
+ $(use_enable minimal tiny)
+ )
+
+ econf "${myconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # Don't use "${ED}" here or things break (#654534)
+ rm -r "${D}"/trash || die
+
+ dodoc doc/sample.nanorc
+ docinto html
+ dodoc doc/faq.html
+ insinto /etc
+ newins doc/sample.nanorc nanorc
+
+ if ! use minimal ; then
+ # Enable colorization by default.
+ sed -i \
+ -e '/^# include /s:# *::' \
+ "${ED}"/etc/nanorc || die
+
+ # Since nano-5.0 these are no longer being "enabled" by default
+ # (bug #736848)
+ local rcdir="/usr/share/nano"
+ mv "${ED}"${rcdir}/extra/* "${ED}"/${rcdir}/ || die
+ rmdir "${ED}"${rcdir}/extra || die
+
+ insinto "${rcdir}"
+ newins "${FILESDIR}/gentoo.nanorc-r1" gentoo.nanorc
+ fi
+
+ use split-usr && dosym ../../bin/nano /usr/bin/nano
+}
+
+pkg_postrm() {
+ [[ -n ${REPLACED_BY_VERSION} ]] && return
+
+ local e
+ e=$(unset EDITOR; . "${EROOT}"/etc/profile &>/dev/null; echo "${EDITOR}")
+ if [[ ${e##*/} == nano ]]; then
+ ewarn "The EDITOR variable is still set to ${e}."
+ ewarn "You can update it with \"eselect editor\"."
+ fi
+}