summaryrefslogtreecommitdiff
path: root/app-editors/nedit/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /app-editors/nedit/files
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'app-editors/nedit/files')
-rw-r--r--app-editors/nedit/files/nedit-5.7-doc.patch13
-rw-r--r--app-editors/nedit/files/nedit-5.7-ldflags.patch17
2 files changed, 30 insertions, 0 deletions
diff --git a/app-editors/nedit/files/nedit-5.7-doc.patch b/app-editors/nedit/files/nedit-5.7-doc.patch
new file mode 100644
index 000000000000..fceb9e1773c8
--- /dev/null
+++ b/app-editors/nedit/files/nedit-5.7-doc.patch
@@ -0,0 +1,13 @@
+--- a/doc/Makefile 2019-05-03 13:18:33.343246393 +0200
++++ b/doc/Makefile 2019-05-03 13:19:33.110902639 +0200
+@@ -48,8 +48,8 @@
+ ../source/help_topic.h ../source/help_data.h: .version help.etx setext
+ @ echo "Creating NEdit help code `cat .version`"
+ @ ./setext -m -v version="`cat .version`" help.etx
+- @ mv -f help_topic.h ../source
+- @ mv -f help_data.h ../source
++ @ cp -f help_topic.h ../source
++ @ cp -f help_data.h ../source
+
+ nedit.html: .version help.etx setext
+ @ echo "Creating NEdit HTML documentation..."
diff --git a/app-editors/nedit/files/nedit-5.7-ldflags.patch b/app-editors/nedit/files/nedit-5.7-ldflags.patch
new file mode 100644
index 000000000000..b529d3327dd2
--- /dev/null
+++ b/app-editors/nedit/files/nedit-5.7-ldflags.patch
@@ -0,0 +1,17 @@
+--- a/source/Makefile.common 2019-01-19 14:27:14.927734607 +0100
++++ b/source/Makefile.common 2019-01-19 14:28:46.186729890 +0100
+@@ -20,12 +20,12 @@
+ # we only want natural rebuilds to regenerate the link date.
+ nedit: $(OBJS) ../util/libNUtil.a $(XMLLIB) $(XLTLIB)
+ $(CC) $(CFLAGS) -c linkdate.c -o linkdate.o
+- $(CC) $(CFLAGS) $(OBJS) linkdate.o $(XMLLIB) \
++ $(CC) $(CFLAGS) $(LDFLAGS) $(OBJS) linkdate.o $(XMLLIB) \
+ $(XLTLIB) ../util/libNUtil.a $(LIBS) -o $@
+
+ # Note LIBS isn't quite right here; it links unnecessarily against Motif
+ nc: nc.o server_common.o ../util/libNUtil.a
+- $(CC) $(CFLAGS) nc.o server_common.o ../util/libNUtil.a $(LIBS) -o $@
++ $(CC) $(CFLAGS) $(LDFLAGS) nc.o server_common.o ../util/libNUtil.a $(LIBS) -o $@
+
+ help.o: help.c
+ $(CC) $(CFLAGS) $(BIGGER_STRINGS) -c help.c -o $@