summaryrefslogtreecommitdiff
path: root/app-editors/neovim/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-31 09:23:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-31 09:23:01 +0100
commit441510fa20665b7920b149994e72b3a1cd62a813 (patch)
tree4bc2e347ca49e5da4915fc3c117c0db31b0ac6cd /app-editors/neovim/files
parent3810dd6a469ba3e0014a390d92f1fc220dd20c3b (diff)
gentoo auto-resync : 31:05:2023 - 09:23:01
Diffstat (limited to 'app-editors/neovim/files')
-rw-r--r--app-editors/neovim/files/neovim-0.8-cmake-darwin.patch65
-rw-r--r--app-editors/neovim/files/neovim-0.8-cmake_lua_version.patch11
-rw-r--r--app-editors/neovim/files/neovim-0.8-msgpack-6.0.0-fix.patch26
-rw-r--r--app-editors/neovim/files/neovim-0.8.0-cmake-release-type.patch28
-rw-r--r--app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch (renamed from app-editors/neovim/files/neovim-9999-cmake-darwin.patch)0
5 files changed, 0 insertions, 130 deletions
diff --git a/app-editors/neovim/files/neovim-0.8-cmake-darwin.patch b/app-editors/neovim/files/neovim-0.8-cmake-darwin.patch
deleted file mode 100644
index ad47a46e1a7a..000000000000
--- a/app-editors/neovim/files/neovim-0.8-cmake-darwin.patch
+++ /dev/null
@@ -1,65 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -80,33 +80,6 @@ set(ENV{PKG_CONFIG_PATH} "$ENV{PKG_CONFIG_PATH}:${DEPS_PREFIX}/lib/pkgconfig")
- # used for check_c_compiler_flag
- include(CheckCCompilerFlag)
-
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin")
-- # CMake tries to treat /sw and /opt/local as extension of the system path, but
-- # that doesn't really work out very well. Once you have a dependency that
-- # resides there and have to add it as an include directory, then any other
-- # dependency that could be satisfied from there must be--otherwise you can end
-- # up with conflicting versions. So, let's make them more of a priority having
-- # them be included as one of the first places to look for dependencies.
-- list(APPEND CMAKE_PREFIX_PATH /sw /opt/local)
--
-- # If the macOS deployment target is not set manually (via $MACOSX_DEPLOYMENT_TARGET),
-- # fall back to local system version. Needs to be done both here and in cmake.deps.
-- if(NOT CMAKE_OSX_DEPLOYMENT_TARGET)
-- execute_process(COMMAND sw_vers -productVersion
-- OUTPUT_VARIABLE MACOS_VERSION
-- OUTPUT_STRIP_TRAILING_WHITESPACE)
-- set(CMAKE_OSX_DEPLOYMENT_TARGET "${MACOS_VERSION}")
-- endif()
-- message("Using deployment target ${CMAKE_OSX_DEPLOYMENT_TARGET}")
--
-- # Work around some old, broken detection by CMake for knowing when to use the
-- # isystem flag. Apple's compilers have supported this for quite some time
-- # now.
-- if(CMAKE_C_COMPILER_ID MATCHES "GNU")
-- set(CMAKE_INCLUDE_SYSTEM_FLAG_C "-isystem ")
-- endif()
--endif()
--
- if(WIN32 OR CMAKE_SYSTEM_NAME STREQUAL "Darwin")
- # Ignore case when comparing filenames on Windows and Mac.
- set(CASE_INSENSITIVE_FILENAME TRUE)
---- a/cmake.deps/CMakeLists.txt
-+++ b/cmake.deps/CMakeLists.txt
-@@ -112,13 +112,6 @@ if(CMAKE_CXX_COMPILER)
- set(DEPS_CXX_COMPILER "${CMAKE_CXX_COMPILER}")
- endif()
-
--if(CMAKE_OSX_SYSROOT)
-- set(DEPS_C_COMPILER "${DEPS_C_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- if(DEPS_CXX_COMPILER)
-- set(DEPS_CXX_COMPILER "${DEPS_CXX_COMPILER} -isysroot${CMAKE_OSX_SYSROOT}")
-- endif()
--endif()
--
- if(CMAKE_OSX_ARCHITECTURES)
- string(REPLACE ";" "|" CMAKE_OSX_ARCHITECTURES_ALT_SEP "${CMAKE_OSX_ARCHITECTURES}")
- # The LuaJIT build does not like being passed multiple `-arch` flags
---- a/src/nvim/CMakeLists.txt
-+++ b/src/nvim/CMakeLists.txt
-@@ -181,10 +181,6 @@ get_directory_property(gen_includes INCLUDE_DIRECTORIES)
- foreach(gen_include ${gen_includes} ${LUA_PREFERRED_INCLUDE_DIRS})
- list(APPEND gen_cflags "-I${gen_include}")
- endforeach()
--if(CMAKE_SYSTEM_NAME STREQUAL "Darwin" AND CMAKE_OSX_SYSROOT)
-- list(APPEND gen_cflags "-isysroot")
-- list(APPEND gen_cflags "${CMAKE_OSX_SYSROOT}")
--endif()
- string(TOUPPER "${CMAKE_BUILD_TYPE}" build_type)
- separate_arguments(C_FLAGS_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS})
- separate_arguments(C_FLAGS_${build_type}_ARRAY UNIX_COMMAND ${CMAKE_C_FLAGS_${build_type}})
diff --git a/app-editors/neovim/files/neovim-0.8-cmake_lua_version.patch b/app-editors/neovim/files/neovim-0.8-cmake_lua_version.patch
deleted file mode 100644
index 87a898032493..000000000000
--- a/app-editors/neovim/files/neovim-0.8-cmake_lua_version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -464,7 +464,7 @@ endif()
- option(PREFER_LUA "Prefer Lua over LuaJIT in the nvim executable." OFF)
-
- if(PREFER_LUA)
-- find_package(Lua 5.1 EXACT REQUIRED)
-+ find_package(Lua ${PREFER_LUA} EXACT REQUIRED)
- set(LUA_PREFERRED_INCLUDE_DIRS ${LUA_INCLUDE_DIR})
- set(LUA_PREFERRED_LIBRARIES ${LUA_LIBRARIES})
- # Passive (not REQUIRED): if LUAJIT_FOUND is not set, nvim-test is skipped.
diff --git a/app-editors/neovim/files/neovim-0.8-msgpack-6.0.0-fix.patch b/app-editors/neovim/files/neovim-0.8-msgpack-6.0.0-fix.patch
deleted file mode 100644
index ce5f7bb86dc4..000000000000
--- a/app-editors/neovim/files/neovim-0.8-msgpack-6.0.0-fix.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-# https://github.com/neovim/neovim/commit/46c4cbced567f5f05f2c95b91cd90084ea8b5528
-# Closes: https://bugs.gentoo.org/903629
-# Contributed by Olivier Huber <oli.huber@gmail.com>
---- a/cmake/FindMsgpack.cmake
-+++ b/cmake/FindMsgpack.cmake
-@@ -26,18 +26,8 @@
- set(MSGPACK_VERSION_STRING)
- endif()
-
--if(MSVC)
-- # The import library for the msgpack DLL has a different name
-- list(APPEND MSGPACK_NAMES msgpackc_import)
--else()
-- list(APPEND MSGPACK_NAMES msgpackc msgpack)
--endif()
--
--find_library(MSGPACK_LIBRARY NAMES ${MSGPACK_NAMES}
-- # Check each directory for all names to avoid using headers/libraries from
-- # different places.
-- NAMES_PER_DIR
-- HINTS ${PC_MSGPACK_LIBDIR} ${PC_MSGPACK_LIBRARY_DIRS})
-+find_library(MSGPACK_LIBRARY NAMES msgpackc msgpack msgpackc_import msgpack-c
-+ NAMES_PER_DIR)
-
- mark_as_advanced(MSGPACK_INCLUDE_DIR MSGPACK_LIBRARY)
-
diff --git a/app-editors/neovim/files/neovim-0.8.0-cmake-release-type.patch b/app-editors/neovim/files/neovim-0.8.0-cmake-release-type.patch
deleted file mode 100644
index 8114e2a92b74..000000000000
--- a/app-editors/neovim/files/neovim-0.8.0-cmake-release-type.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-Ensure that :checkhealth is happy with the Gentoo build type.
-https://bugs.gentoo.org/757744
---- a/runtime/autoload/health/nvim.vim
-+++ b/runtime/autoload/health/nvim.vim
-@@ -135,7 +135,7 @@ function! s:check_performance() abort
- let buildtype = matchstr(execute('version'), '\v\cbuild type:?\s*[^\n\r\t ]+')
- if empty(buildtype)
- call health#report_error('failed to get build type from :version')
-- elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo)'
-+ elseif buildtype =~# '\v(MinSizeRel|Release|RelWithDebInfo|Gentoo)'
- call health#report_ok(buildtype)
- else
- call health#report_info(buildtype)
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -137,12 +137,6 @@ else()
- message(STATUS "MIN_LOG_LEVEL=${MIN_LOG_LEVEL}")
- endif()
-
--# Default to -O2 on release builds.
--if(CMAKE_C_FLAGS_RELEASE MATCHES "-O3")
-- message(STATUS "Replacing -O3 in CMAKE_C_FLAGS_RELEASE with -O2")
-- string(REPLACE "-O3" "-O2" CMAKE_C_FLAGS_RELEASE "${CMAKE_C_FLAGS_RELEASE}")
--endif()
--
- if(CMAKE_C_COMPILER_ID MATCHES "GNU")
- check_c_compiler_flag(-Og HAS_OG_FLAG)
- else()
diff --git a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch b/app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch
index 1488148298bd..1488148298bd 100644
--- a/app-editors/neovim/files/neovim-9999-cmake-darwin.patch
+++ b/app-editors/neovim/files/neovim-0.9.1-cmake-darwin.patch