summaryrefslogtreecommitdiff
path: root/app-editors/neovim/neovim-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /app-editors/neovim/neovim-9999.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'app-editors/neovim/neovim-9999.ebuild')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild8
1 files changed, 4 insertions, 4 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 97f2f678904d..6647b38da751 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit cmake-utils eutils xdg
+inherit cmake eutils xdg
DESCRIPTION="Vim-fork focused on extensibility and agility."
HOMEPAGE="https://neovim.io"
@@ -59,7 +59,7 @@ src_prepare() {
sed -e "/^# define SYS_VIMRC_FILE/s|\$VIM|${EPREFIX}/etc/vim|" \
-i src/nvim/globals.h || die
- cmake-utils_src_prepare
+ cmake_src_prepare
}
src_configure() {
@@ -67,11 +67,11 @@ src_configure() {
-DFEAT_TUI=$(usex tui)
-DPREFER_LUA=$(usex luajit no yes)
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
# install a default configuration file
insinto /etc/vim