summaryrefslogtreecommitdiff
path: root/app-editors/neovim/neovim-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /app-editors/neovim/neovim-9999.ebuild
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'app-editors/neovim/neovim-9999.ebuild')
-rw-r--r--app-editors/neovim/neovim-9999.ebuild23
1 files changed, 17 insertions, 6 deletions
diff --git a/app-editors/neovim/neovim-9999.ebuild b/app-editors/neovim/neovim-9999.ebuild
index 28da413392a7..bab41265d1f7 100644
--- a/app-editors/neovim/neovim-9999.ebuild
+++ b/app-editors/neovim/neovim-9999.ebuild
@@ -1,11 +1,13 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-inherit cmake-utils
+EAPI=7
+
+inherit cmake-utils xdg-utils
DESCRIPTION="Vim-fork focused on extensibility and agility."
HOMEPAGE="https://neovim.io"
+
if [[ ${PV} == 9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/neovim/neovim.git"
@@ -18,8 +20,8 @@ LICENSE="Apache-2.0 vim"
SLOT="0"
IUSE="+clipboard +luajit +nvimpager python remote ruby +tui +jemalloc"
-CDEPEND=">=dev-libs/libuv-1.2.0
- >=dev-libs/msgpack-1.0.0
+CDEPEND=">=dev-libs/libuv-1.2.0:0=
+ >=dev-libs/msgpack-1.0.0:0=
luajit? ( dev-lang/luajit:2 )
!luajit? (
dev-lang/lua:=
@@ -27,12 +29,13 @@ CDEPEND=">=dev-libs/libuv-1.2.0
)
tui? (
>=dev-libs/libtermkey-0.19
- >=dev-libs/unibilium-2.0.0
+ >=dev-libs/unibilium-2.0.0:0=
)
dev-libs/libvterm
dev-lua/lpeg[luajit=]
dev-lua/mpack[luajit=]
- jemalloc? ( dev-libs/jemalloc )"
+ jemalloc? ( dev-libs/jemalloc )
+ net-libs/libnsl"
DEPEND="
${CDEPEND}
@@ -81,3 +84,11 @@ src_install() {
dosym ../share/nvim/runtime/macros/less.sh /usr/bin/nvimpager
fi
}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}