summaryrefslogtreecommitdiff
path: root/app-editors/pluma-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 02:58:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 02:58:11 +0000
commitfbe7acf59ebf6dc3f04a6ef108ff3887fa5d7972 (patch)
tree3669828a2d0c5f7cb1a4bfd79be8032aac558282 /app-editors/pluma-plugins
parent9bc9c4dcc38dc560cff8e5d083d1e5f282ddde98 (diff)
gentoo auto-resync : 03:12:2022 - 02:58:11
Diffstat (limited to 'app-editors/pluma-plugins')
-rw-r--r--app-editors/pluma-plugins/Manifest3
-rw-r--r--app-editors/pluma-plugins/metadata.xml15
-rw-r--r--app-editors/pluma-plugins/pluma-plugins-1.26.0.ebuild71
3 files changed, 89 insertions, 0 deletions
diff --git a/app-editors/pluma-plugins/Manifest b/app-editors/pluma-plugins/Manifest
new file mode 100644
index 000000000000..7128e7bcbcb9
--- /dev/null
+++ b/app-editors/pluma-plugins/Manifest
@@ -0,0 +1,3 @@
+DIST pluma-plugins-1.26.0.tar.xz 505652 BLAKE2B 09d34a3205796aab0b94b6e4d1c44b9902091b46511735b74a9cc1d1bee8a28352bf673ea7788eb4522e1dd0614a0399471aa8a076fd50f70bf1cf66e80326ad SHA512 ee59d52e0f879a5adf745c4be4a274f5c5b5403d7a9485236879e6e6db1c8f743de74be379fe84d2da73efe3eeb63bfa089a28f73762a6f0ceee0dbbbc464fa4
+EBUILD pluma-plugins-1.26.0.ebuild 1606 BLAKE2B 716c337fbe251be1b095d90003a828ead10acfdb4eeb80b4ea6700efdfbd884c92ba44dfae0bba63f015f2c99e7dfe5dc836dcb2538b8e90593b921aa1455ebf SHA512 403150d7b11f0693aa82af41e1790e4f9491874c5557a948b1ce135eeb0c766a15668adc5882248482fd12ab82954656c4b741d2e66dacf848cd7733e457a7d3
+MISC metadata.xml 564 BLAKE2B a36e6a042e600b7370e8ab7ea125655fa4d0e2ebe796e1dfd06378b42625959d33bc7c70dd6a54d3ee3686fb190d52654606805f28953ae57b771961acc8e9cf SHA512 2acb64c7a5018b6cf5ef5b5e93c43b6fe1aa07dcee1d26cd3e285e8eb61c49c361272187cfa8641c904f044c1cfed9e6c4424a4ed8540bf063cfb6336e9cb0bc
diff --git a/app-editors/pluma-plugins/metadata.xml b/app-editors/pluma-plugins/metadata.xml
new file mode 100644
index 000000000000..62ccd0b85014
--- /dev/null
+++ b/app-editors/pluma-plugins/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>mate@gentoo.org</email>
+ <name>Gentoo MATE Desktop</name>
+</maintainer>
+<use>
+ <flag name="bracketcompletion">Auto complete bracket pairs</flag>
+ <flag name="codecomment">Comment code blocks</flag>
+ <flag name="smartspaces">Insert smart spaces</flag>
+ <flag name="synctex">Enable synctex support for pdflatex</flag>
+ <flag name="terminal">Embed a terminal in the bottom pane</flag>
+</use>
+</pkgmetadata>
diff --git a/app-editors/pluma-plugins/pluma-plugins-1.26.0.ebuild b/app-editors/pluma-plugins/pluma-plugins-1.26.0.ebuild
new file mode 100644
index 000000000000..ea5d9255a604
--- /dev/null
+++ b/app-editors/pluma-plugins/pluma-plugins-1.26.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit mate python-single-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A set of plugins for Pluma, the MATE text editor."
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT="0"
+
+IUSE="+python bracketcompletion codecomment smartspaces synctex terminal"
+REQUIRED_USE="
+ "${PYTHON_REQUIRED_USE}"
+ bracketcompletion? ( python )
+ codecomment? ( python )
+ smartspaces? ( python )
+ synctex? ( python )
+ terminal? ( python )
+ "
+
+RDEPEND="
+ >=dev-libs/libpeas-1.14.1[gtk]
+ >=app-editors/gedit-40.0
+
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.9:3
+ >=x11-libs/gtksourceview-4.0.2:4
+
+ python? (
+ ${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ app-editors/gedit[python,${PYTHON_SINGLE_USEDEP}]
+ dev-libs/libpeas[python,${PYTHON_SINGLE_USEDEP}]
+ >=dev-python/dbus-python-0.82[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ ')
+ >=x11-libs/gtk+-3.9:3[introspection]
+ >=x11-libs/gtksourceview-4.0.2:4[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ synctex? ( >=dev-python/dbus-python-0.82 )
+ terminal? ( >=x11-libs/vte-0.52:2.91[introspection] )
+
+ )"
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-libs/libxml2
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ use python && python-single-r1_pkg_setup
+}
+
+src_install() {
+ mate_src_install
+ use python && python_optimize "${ED}/usr/$(get_libdir)/gedit/plugins/"
+}