summaryrefslogtreecommitdiff
path: root/app-editors/pluma
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-21 13:58:21 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-21 13:58:21 +0000
commitd8e7aaf1b90b28ec354e7854abea07d53644e754 (patch)
treea3dfecdac470c25645b7bcacd4923343eec46afe /app-editors/pluma
parenta473f013073f9c57e59e7d30f088eee89312dd0d (diff)
gentoo auto-resync : 21:12:2023 - 13:58:21
Diffstat (limited to 'app-editors/pluma')
-rw-r--r--app-editors/pluma/Manifest2
-rw-r--r--app-editors/pluma/pluma-1.27.0.ebuild84
2 files changed, 86 insertions, 0 deletions
diff --git a/app-editors/pluma/Manifest b/app-editors/pluma/Manifest
index cf6fc1c35c3e..79eb9ebe6576 100644
--- a/app-editors/pluma/Manifest
+++ b/app-editors/pluma/Manifest
@@ -1,4 +1,6 @@
AUX pluma-1.26.0-fortify-source-3.patch 998 BLAKE2B 84536f238237d929e6af4362be3ee6c95329170efa2e862b93fce96ef7dd689732e2e4df4b533745254ebde7504b65b0b55c2cdcd817186738f67de889eeb5d3 SHA512 c5e4a56ecebaeb0bf58fc62daac0f4a0dd685ac758648672d1ed13c2abf51453e219aa0ce3c52e04386a80491fb4f43ed042ac32086f6eb6d73553e79ccf0575
DIST pluma-1.26.0.tar.xz 3765056 BLAKE2B 4a3107df7c4ba906d405b5ef3ea6dd9ca0e372a7b00224213fc8a60d1dc26663d1363aa7f0569b0242407f5b5d850386308fae9192c4a33f577295bb55ef5a16 SHA512 a6c0cee7110f4863e44af51b19bb528f0f3570eab8db98038152bf142eedde97ac13b896deff7051b941a0f43c6fe14e316a97eba40fe5d4854d76038450245f
+DIST pluma-1.27.0.tar.xz 3820196 BLAKE2B 877b1856154e79aade7b709b5da0584cb426f07d69305d98af6f9954b8934f99241b750c0322ca7418db69c6fac1b4a1b6d8ffc3e75b441ffa5760ec0cd1d1d3 SHA512 ce2ab6fb4f7cfa93b8b1c22a80b4a688f63f9ec61fd173c22684a9cb49a83551cc9e5ed45a04cec23683d85be059615d90abd7d6b7e4b3bf1b3d6287d4292f78
EBUILD pluma-1.26.0-r2.ebuild 1882 BLAKE2B 611c364e2e507989b074e460a9bbedf6f13b681db5171a7b8aca08fc002880c3fc5907d121fbe0b540a668cb37dab28b495d6ac472808f79714e8031a5c1c948 SHA512 d8cba66c3dff7947434885f3c8cc116d5bcc610044e2a752d03217d8ee7aef46a04148552a420c4b823222fe5d5eede6d7f2e94dc4413f3f60918227ce410dd4
+EBUILD pluma-1.27.0.ebuild 1907 BLAKE2B bd42f28dc83e52296594daec9ae9b489b93bb767b48f7a40f1c83e8113493c7b9483a79c286d46b810d1c9d17a5af6b59b6f0aefc16ede7e7130542b6647e425 SHA512 a5afda390c4f657af8d78cae671f07f1907f4392a0460dcc0449795fe059582b5768ac0de29126b2f9ea852c482f338d710150331cbf67c58984930b93ccbc50
MISC metadata.xml 251 BLAKE2B 1e59e3a725c8495f2caa8e5fa4d5abffb12997608d2d226866543584ca61872d794f1fd6ee776fe15a7bcffbc6a1d24f70b5210c81675a9ff003cad23ffc89a2 SHA512 99d8dc72eda726ff317db29bca6e65732b78a35c396043e1093138bcfc68ad4984e1536fadbc129a2440029e7b1873d441844c10cf175812bd566ee3fd5127eb
diff --git a/app-editors/pluma/pluma-1.27.0.ebuild b/app-editors/pluma/pluma-1.27.0.ebuild
new file mode 100644
index 000000000000..87f8c1a30b48
--- /dev/null
+++ b/app-editors/pluma/pluma-1.27.0.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MATE_LA_PUNT="yes"
+PYTHON_COMPAT=( python3_{9..11} )
+inherit mate python-single-r1 virtualx
+
+DESCRIPTION="Pluma text editor for the MATE desktop"
+
+MINOR=$(($(ver_cut 2) % 2))
+if [[ ${MINOR} -eq 0 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+else
+ KEYWORDS=""
+fi
+
+LICENSE="FDL-1.1+ GPL-2+ LGPL-2+"
+SLOT=0
+IUSE="+introspection spell test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libpeas-1.2.0:0[gtk]
+ >=dev-libs/libxml2-2.5:2
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3[introspection?]
+ >=x11-libs/gtksourceview-4.0.2:4
+ x11-libs/libICE
+ x11-libs/libX11
+ >=x11-libs/libSM-1.0
+ x11-libs/pango
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+ spell? (
+ >=app-text/enchant-1.6:=
+ >=app-text/iso-codes-0.35
+ )
+"
+RDEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ >=mate-base/mate-desktop-1.9[introspection?]
+ virtual/libintl
+"
+DEPEND="${COMMON_DEPEND}
+ ~app-text/docbook-xml-dtd-4.1.2
+ app-text/yelp-tools
+ dev-util/glib-utils
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=sys-devel/libtool-2.2.6:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+MATE_FORCE_AUTORECONF=true
+
+src_prepare() {
+ # Test require gvfs sftp fs mounted and schema's installed. Skip this one.
+ # https://github.com/mate-desktop/mate-text-editor/issues/33
+ sed -e '/+= document-saver/d' -i tests/Makefile.am || die
+
+ mate_src_prepare
+}
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable introspection) \
+ $(use_enable spell) \
+ $(use_enable test tests)
+}
+
+src_test() {
+ # FIXME: This should be handled at eclass level.
+ "${EPREFIX}/${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+
+ unset DBUS_SESSION_BUS_ADDRESS
+ local -x GSETTINGS_SCHEMA_DIR="${S}/data"
+ virtx emake check
+}