summaryrefslogtreecommitdiff
path: root/app-editors/pyvim/pyvim-3.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
commitb3f2504c1d05b5999b74b2135860fc721e3adf68 (patch)
treee11656067365c7d474553833d6202ed04d3324a5 /app-editors/pyvim/pyvim-3.0.3.ebuild
parente0fdb8199de0e7a9b7c72d7f38d2e3ddaecdacd0 (diff)
gentoo auto-resync : 15:07:2022 - 07:41:50
Diffstat (limited to 'app-editors/pyvim/pyvim-3.0.3.ebuild')
-rw-r--r--app-editors/pyvim/pyvim-3.0.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-editors/pyvim/pyvim-3.0.3.ebuild b/app-editors/pyvim/pyvim-3.0.3.ebuild
new file mode 100644
index 000000000000..a82ef87a6274
--- /dev/null
+++ b/app-editors/pyvim/pyvim-3.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 edo
+
+COMMIT="14118ad2e4d0da2e955fd9069b8772408307618b"
+DESCRIPTION="An implementation of Vim in Python"
+HOMEPAGE="https://pypi.org/project/pyvim/ https://github.com/prompt-toolkit/pyvim"
+SRC_URI="https://github.com/prompt-toolkit/${PN}/archive/${COMMIT}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/prompt_toolkit[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+"
+IDEPEND="
+ app-eselect/eselect-vi
+"
+
+distutils_enable_tests pytest
+
+eselect_vi_update() {
+ edob eselect vi update --if-unset
+}
+
+pkg_postinst() {
+ eselect_vi_update
+}
+
+pkg_postrm() {
+ eselect_vi_update
+}