summaryrefslogtreecommitdiff
path: root/app-editors/pyvim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-editors/pyvim
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-editors/pyvim')
-rw-r--r--app-editors/pyvim/Manifest3
-rw-r--r--app-editors/pyvim/metadata.xml16
-rw-r--r--app-editors/pyvim/pyvim-3.0.2.ebuild39
3 files changed, 58 insertions, 0 deletions
diff --git a/app-editors/pyvim/Manifest b/app-editors/pyvim/Manifest
new file mode 100644
index 000000000000..59cde71f0e8d
--- /dev/null
+++ b/app-editors/pyvim/Manifest
@@ -0,0 +1,3 @@
+DIST pyvim-3.0.2.tar.gz 35227 BLAKE2B 8edc2218b3a0f2ba922531b75f65a5273ad9a2697f72ecf994cf7d2406c6311c3f28b22b6adb1243150a90db74962256ceaa7cf47ec99c2388299742451d6efb SHA512 da961342ba52e5beca44a607cbb923953388e8674409db9ca2b152017eeedce84f92e42a9f6d0e5019c5c4d88d82f4a987cb378f311cf84a169cefa54dc5efce
+EBUILD pyvim-3.0.2.ebuild 843 BLAKE2B 797269dcef0f96efc18709ee4d7e6e0c5a95eab904022c6b9ea348460574c134678c6afba1bc00f9c1915c6839c064ce84d5b5d5859212bf8a0b70974c2fe35d SHA512 b5e388b2e74d78fffe5f7414f6d2608ab6b0a0ef6d001dbf918c41b055938b9878e3940e92a8686beafb2945e5bfe76d7b98a6bf120cb166166c54399d9b90bf
+MISC metadata.xml 489 BLAKE2B c68a02d61b1c1e6f577c4fa415ce88e93cb4fad16418800dbdb5121baba72f521f18c1d253089835b7b99ff94e6f095051974dfadc5c55b6dc33a52ac6b25b58 SHA512 8ad8692c0a2e47b5135497d49c4a5676607e429a5281b7bfc3f9f0ba6e77195020218f1a444cfd587deee7a7cd2cd6f56ff28d66392f14b5b48203097b08680a
diff --git a/app-editors/pyvim/metadata.xml b/app-editors/pyvim/metadata.xml
new file mode 100644
index 000000000000..318dcc191ea8
--- /dev/null
+++ b/app-editors/pyvim/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>monsieurp@gentoo.org</email>
+ <name>Patrice Clement</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyvim</remote-id>
+ <remote-id type="github">prompt-toolkit/pyvim</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-editors/pyvim/pyvim-3.0.2.ebuild b/app-editors/pyvim/pyvim-3.0.2.ebuild
new file mode 100644
index 000000000000..f0ba40a9fbc0
--- /dev/null
+++ b/app-editors/pyvim/pyvim-3.0.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of Vim in Python"
+HOMEPAGE="https://pypi.org/project/pyvim https://github.com/prompt-toolkit/pyvim"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-eselect/eselect-vi
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/docopt[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/prompt_toolkit[${PYTHON_USEDEP}]"
+
+eselect_vi_update() {
+ einfo "Calling eselect vi update..."
+ eselect vi update --if-unset
+ eend $?
+}
+
+pkg_postinst() {
+ eselect_vi_update
+}
+
+pkg_postrm() {
+ eselect_vi_update
+}