summaryrefslogtreecommitdiff
path: root/app-editors/qhexedit2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-editors/qhexedit2/files
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-editors/qhexedit2/files')
-rw-r--r--app-editors/qhexedit2/files/qhexedit2-0.8.9.patch36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-editors/qhexedit2/files/qhexedit2-0.8.9.patch b/app-editors/qhexedit2/files/qhexedit2-0.8.9.patch
new file mode 100644
index 000000000000..cabbd77ac843
--- /dev/null
+++ b/app-editors/qhexedit2/files/qhexedit2-0.8.9.patch
@@ -0,0 +1,36 @@
+diff --git a/setup.py b/setup.py
+index 1a0d912..646c359 100644
+--- a/setup.py
++++ b/setup.py
+@@ -98,7 +98,7 @@ if cfg.qt_framework:
+ lib + ".framework", "Headers")]
+ else:
+ if PyQt_Version == 'PyQt5':
+- for qt_inc_dir in ('/usr/include/qt', '/usr/include/x86_64-linux-gnu/qt5'):
++ for qt_inc_dir in ('/usr/include/qt', '/usr/include/qt5'):
+ include_dirs.append(qt_inc_dir)
+ include_dirs += [os.path.join(qt_inc_dir, lib) for lib in qt_libs]
+ libraries = ["Qt5" + lib[2:] for lib in qt_libs]
+diff --git a/src/qhexedit.pro b/src/qhexedit.pro
+index 2a94016..55d7bc2 100644
+--- a/src/qhexedit.pro
++++ b/src/qhexedit.pro
+@@ -23,5 +23,7 @@ Release:TARGET = qhexedit
+ Debug:TARGET = qhexeditd
+
+
+-unix:DESTDIR = /usr/lib
+ win32:DESTDIR = ../lib
++
++target.path = /usr/lib64
++INSTALLS += target
+diff --git a/src/qhexedit.sip b/src/qhexedit.sip
+index 082621e..a7ef4e7 100644
+--- a/src/qhexedit.sip
++++ b/src/qhexedit.sip
+@@ -1,4 +1,4 @@
+-%Module(name=qhexedit, version=1)
++%Module(name=qhexedit)
+
+ %Import QtCore/QtCoremod.sip
+ %Import QtGui/QtGuimod.sip