summaryrefslogtreecommitdiff
path: root/app-editors/retext/retext-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-editors/retext/retext-9999.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-editors/retext/retext-9999.ebuild')
-rw-r--r--app-editors/retext/retext-9999.ebuild22
1 files changed, 8 insertions, 14 deletions
diff --git a/app-editors/retext/retext-9999.ebuild b/app-editors/retext/retext-9999.ebuild
index 44d48af58513..72e36651206d 100644
--- a/app-editors/retext/retext-9999.ebuild
+++ b/app-editors/retext/retext-9999.ebuild
@@ -3,11 +3,12 @@
EAPI=7
-# no pypy{,3} support as PyQt5 does not support it at 2019-05-15
+# no pypy{,3} support as PyQt5 does not support it at 2020-07-05 (towelday)
# https://bitbucket.org/pypy/compatibility/wiki/Home#!gui-library-bindings
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{7,8,9} )
inherit distutils-r1 virtualx xdg-utils
+DISTUTILS_USE_SETUPTOOLS=rdepend
MY_PN="ReText"
MY_P="${MY_PN}-${PV/_/~}"
@@ -27,7 +28,7 @@ fi
LICENSE="GPL-2+"
SLOT="0"
-IUSE="+spell"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/chardet[${PYTHON_USEDEP}]
@@ -37,18 +38,9 @@ RDEPEND="
dev-python/pygments[${PYTHON_USEDEP}]
dev-python/python-markdown-math[${PYTHON_USEDEP}]
dev-python/PyQt5[gui,network,printsupport,widgets,${PYTHON_USEDEP}]
- || (
- dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
- <dev-python/PyQt5-5.12[webengine]
- )
- spell? ( dev-python/pyenchant[${PYTHON_USEDEP}] )
-"
-DEPEND="
- ${RDEPEND}
-"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/PyQtWebEngine[${PYTHON_USEDEP}]
"
+DEPEND="${RDEPEND}"
src_test() {
virtx distutils-r1_src_test
@@ -62,6 +54,8 @@ pkg_postinst() {
xdg_desktop_database_update
xdg_icon_cache_update
+ optfeature "dictionary support" dev-python/pyenchant
+
einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
einfo "For more details take a look at:"