summaryrefslogtreecommitdiff
path: root/app-editors/retext/retext-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-14 12:12:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-14 12:12:48 +0100
commitb6323af2602e6a5cd4920d4af06b5c2f3949b9d0 (patch)
tree7d427f015930068f8d06e8f5aa622635ac3b61ca /app-editors/retext/retext-9999.ebuild
parent4b61f038fc5ecca26609a997fcc662c7cf9e0498 (diff)
gentoo auto-resync : 14:08:2023 - 12:12:48
Diffstat (limited to 'app-editors/retext/retext-9999.ebuild')
-rw-r--r--app-editors/retext/retext-9999.ebuild19
1 files changed, 13 insertions, 6 deletions
diff --git a/app-editors/retext/retext-9999.ebuild b/app-editors/retext/retext-9999.ebuild
index 7f375768199a..aa9aaadfcf57 100644
--- a/app-editors/retext/retext-9999.ebuild
+++ b/app-editors/retext/retext-9999.ebuild
@@ -3,14 +3,12 @@
EAPI=8
-# Please don't add pypy support before testing if it's actually supported. The
-# old compat matrix is no longer accessible as of 2021-02-13 but stated back
-# in 2020-07-05 that PyQt5 was explicitly not supported.
+DISTUTILS_USE_PEP517="setuptools"
PYTHON_COMPAT=( python3_{9..11} )
PYPI_NO_NORMALIZE=1
PYPI_PN="ReText"
-inherit distutils-r1 optfeature qmake-utils virtualx xdg
+inherit desktop distutils-r1 optfeature qmake-utils virtualx xdg
DESCRIPTION="Simple editor for Markdown and reStructuredText"
HOMEPAGE="https://github.com/retext-project/retext https://github.com/retext-project/retext/wiki"
@@ -49,6 +47,13 @@ pkg_setup() {
export PATH="$(qt5_get_bindir):${PATH}"
}
+python_install() {
+ distutils-r1_python_install
+
+ newicon data/retext-kde5.png retext.png
+ make_desktop_entry ${PN} "ReText" ${PN} "Office;WordProcessor"
+}
+
src_test() {
virtx distutils-r1_src_test
}
@@ -61,11 +66,13 @@ pkg_postinst() {
xdg_pkg_postinst
optfeature "dictionary support" dev-python/pyenchant
- # See https://bugs.gentoo.org/772197.
- optfeature "rendering with webengine" dev-python/PyQt6-WebEngine
einfo "Starting with retext-7.0.4 the markdown-math plugin is installed."
einfo "Note that you can use different math delimiters, e.g. \(...\) for inline math."
einfo "For more details take a look at:"
einfo "https://github.com/mitya57/python-markdown-math#math-delimiters"
}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}