summaryrefslogtreecommitdiff
path: root/app-editors/sandy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/sandy
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/sandy')
-rw-r--r--app-editors/sandy/Manifest4
-rw-r--r--app-editors/sandy/files/sandy-0.4-gentoo.patch49
-rw-r--r--app-editors/sandy/metadata.xml7
-rw-r--r--app-editors/sandy/sandy-0.4.ebuild30
4 files changed, 90 insertions, 0 deletions
diff --git a/app-editors/sandy/Manifest b/app-editors/sandy/Manifest
new file mode 100644
index 000000000000..9441cf85577f
--- /dev/null
+++ b/app-editors/sandy/Manifest
@@ -0,0 +1,4 @@
+AUX sandy-0.4-gentoo.patch 1019 BLAKE2B 8aafad7b55d55fee1e48105f77b321929e306341cb318a89cc500089249988de33fba50a67a24a7868f1d6737a3130717cd38b40a132a28f36da1e1248da4053 SHA512 06e3e4dd2979e3589f9f1205eee13c56006ea4f2d8d8ead61faadebcdc9b590c82b645dc93b6ed6693cd15cd8d7e45491812fa3fb0819cfd088e5e231da7f7ab
+DIST sandy-0.4.tar.bz2 18409 BLAKE2B bb10bc7def440d436ffa0304c8f009d722b23159fdd8f2b559f768476391ba2ddda9083ef6fd7e0cec32b231d3c6fa9578214e5027b8a4cd490d338b384ea83a SHA512 6f28588e15ccdc467dd9d0de8b221508333defefe5866005d82292583db9f296284f233271af5e85b648c194dff117f94752cc364ed6c1409dae5c3af755b530
+EBUILD sandy-0.4.ebuild 680 BLAKE2B d7133d25632aa6f321dbf51970b2bb8c629e9be3b0fbeedacf7e11d93e065b1b11f2896251676d34e31acfc334e7577236036297a76cdf8621581f50693a8056 SHA512 1bd2f870bca21d66e7d53ede12c92bea99fcec61c970b7ba885f438f9e43584bbe340ee780e0e0410d2c9e5701088db9db06331e65156bc925c8a680ef709695
+MISC metadata.xml 210 BLAKE2B bb9591af5406abbf589664053ab6e5cb38933fe6ef97c11609405392b050b26cff8e94e04e85e5798124abd46283bee67b2a74923a5041616df15aaa9cff6da9 SHA512 f7cbe57a24b67a28696f91061ad8bd61d7d4cf3d59d20c3dcc6a4921e29672d00ecf3ece70a8813399d2467ebd626f8f829300e81fc722e9aaa527e213a5fb54
diff --git a/app-editors/sandy/files/sandy-0.4-gentoo.patch b/app-editors/sandy/files/sandy-0.4-gentoo.patch
new file mode 100644
index 000000000000..877c96805ef4
--- /dev/null
+++ b/app-editors/sandy/files/sandy-0.4-gentoo.patch
@@ -0,0 +1,49 @@
+--- a/config.mk
++++ b/config.mk
+@@ -9,19 +9,19 @@
+
+ # includes and libs (ncurses)
+ INCS = -I. -I/usr/include
+-LIBS = -L/usr/lib -lc -lncursesw
++LIBS = $(shell ${PKG_CONFIG} --libs ncurses)
+
+ # flags
+-CPPFLAGS = -DVERSION=\"${VERSION}\"
++CPPFLAGS = -DVERSION=\"${VERSION}\" -D_DEFAULT_SOURCE
+ #CFLAGS = -std=c99 -pedantic -Wall -Os ${INCS} ${CPPFLAGS}
+ #LDFLAGS = -s ${LIBS}
+-CFLAGS = -g -std=c99 -pedantic -Wall -O0 ${INCS} ${CPPFLAGS}
+-LDFLAGS = ${LIBS}
++CFLAGS += -std=c99 -pedantic -Wall ${INCS} ${CPPFLAGS}
++LDFLAGS += ${LIBS}
+
+ # Solaris
+ #CFLAGS = -fast ${INCS} -DVERSION=\"${VERSION}\"
+ #LDFLAGS = ${LIBS}
+
+ # compiler and linker
+-CC = cc
++CC ?= cc
+
+--- a/Makefile
++++ b/Makefile
+@@ -15,8 +15,7 @@
+ @echo "CC = ${CC}"
+
+ .c.o:
+- @echo CC $<
+- @${CC} -c ${CFLAGS} $<
++ ${CC} -c ${CFLAGS} $<
+
+ ${OBJ}: config.h config.mk
+
+@@ -25,8 +24,7 @@
+ @cp config.def.h $@
+
+ sandy: ${OBJ}
+- @echo CC -o $@
+- @${CC} -o $@ sandy.o ${LDFLAGS}
++ ${CC} ${CFLAGS} -o $@ sandy.o ${LDFLAGS}
+
+ clean:
+ @echo cleaning
diff --git a/app-editors/sandy/metadata.xml b/app-editors/sandy/metadata.xml
new file mode 100644
index 000000000000..5ba62861f1c4
--- /dev/null
+++ b/app-editors/sandy/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+<email>jer@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/app-editors/sandy/sandy-0.4.ebuild b/app-editors/sandy/sandy-0.4.ebuild
new file mode 100644
index 000000000000..d401639ce641
--- /dev/null
+++ b/app-editors/sandy/sandy-0.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="an ncurses text editor with an easy-to-read, hackable C source"
+HOMEPAGE="https://tools.suckless.org/sandy"
+SRC_URI="https://git.suckless.org/${PN}/snapshot/${P}.tar.bz2"
+
+LICENSE="MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="sys-libs/ncurses:0="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.4-gentoo.patch
+}
+
+src_compile() {
+ tc-export CC PKG_CONFIG
+ append-cflags -D_DEFAULT_SOURCE
+ emake PREFIX=/usr ${PN}
+}
+
+src_install() {
+ emake PREFIX=/usr DESTDIR="${D}" install
+}