summaryrefslogtreecommitdiff
path: root/app-editors/tea
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-editors/tea
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-editors/tea')
-rw-r--r--app-editors/tea/Manifest3
-rw-r--r--app-editors/tea/metadata.xml18
-rw-r--r--app-editors/tea/tea-44.1.1.ebuild65
3 files changed, 86 insertions, 0 deletions
diff --git a/app-editors/tea/Manifest b/app-editors/tea/Manifest
new file mode 100644
index 000000000000..040ce6e0c60f
--- /dev/null
+++ b/app-editors/tea/Manifest
@@ -0,0 +1,3 @@
+DIST tea-44.1.1.tar.bz2 425326 BLAKE2B e674456c428bbecd5afb256280bccb61b6385492153955625c158dcfebba0ed31caebdcc06bc1f809517badddef3d97245a4bc873bcc0593957647becdebf62b SHA512 fc7bf6f76ac3a48767a39ff5bcada4c7dae40950bfd9aca4021b3581e1b702c73f2608b070306dd528932d5eaa73bf01632a4376bbb71deaf1189a0f790c05a9
+EBUILD tea-44.1.1.ebuild 1366 BLAKE2B ed9163609bb1041fce04663549f72f500744983b064d3aabf2d85540aed1770b13c36ab877364b7c7209cfa92dabce0a0e7aa826f1fb8278273364cc87c99354 SHA512 42c773cc51d323faf9e4546398bf37258795583ad17699f0de5a6dcb2e9f469df172b38f1d0cdc50af8f081e1356d57f3e0f31fb31abe28530157147f92411fa
+MISC metadata.xml 737 BLAKE2B 891e84e0d4bef855f64e09d795bb57c8dbac9906529d311716047b2aabd08f1ec93a28d0f61652a5d7af21fae8ac8e920bca68492ddc79db6e3d0d02d091b2cf SHA512 f253f80583e79be7b0e03ec3515e2e1e48425fd7bb520422e0c2883fc2da07b7e1b5f83d6c7d4e6317a47b2179f7627b8975493b82e800241530aa2b42efd6a6
diff --git a/app-editors/tea/metadata.xml b/app-editors/tea/metadata.xml
new file mode 100644
index 000000000000..a3b87502efe6
--- /dev/null
+++ b/app-editors/tea/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>qt@gentoo.org</email>
+ <name>Gentoo Qt Project</name>
+ </maintainer>
+ <longdescription>
+ A very small Qt text editor. It has lots of extra features including syntax
+ highlighting and a built in file manager as well as a built in image viewer.
+ It can also read lots of 'other' filetypes.
+ </longdescription>
+ <use>
+ <flag name="aspell">Enable spellchecking using <pkg>app-text/aspell</pkg></flag>
+ <flag name="hunspell">Enable spellchecking using <pkg>app-text/hunspell</pkg></flag>
+ <flag name="qml">Enable support for plugins using QML</flag>
+ </use>
+</pkgmetadata>
diff --git a/app-editors/tea/tea-44.1.1.ebuild b/app-editors/tea/tea-44.1.1.ebuild
new file mode 100644
index 000000000000..e2cc47fd239b
--- /dev/null
+++ b/app-editors/tea/tea-44.1.1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils qmake-utils xdg-utils
+
+DESCRIPTION="Small, lightweight Qt text editor"
+HOMEPAGE="https://tea.ourproject.org/"
+SRC_URI="https://tea.ourproject.org/dloads/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd"
+IUSE="aspell djvu hunspell pdf +qml"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtnetwork:5
+ dev-qt/qtprintsupport:5
+ dev-qt/qtwidgets:5
+ sys-libs/zlib
+ aspell? ( app-text/aspell )
+ djvu? ( app-text/djvu )
+ hunspell? ( app-text/hunspell:= )
+ pdf? ( app-text/poppler[qt5] )
+ qml? ( dev-qt/qtdeclarative:5 )
+"
+DEPEND="${RDEPEND}
+ hunspell? ( virtual/pkgconfig )
+"
+
+DOCS=( AUTHORS ChangeLog NEWS NEWS-RU TODO )
+
+src_configure() {
+ eqmake5 src.pro \
+ PREFIX="/usr" \
+ $(use aspell || echo CONFIG+=noaspell) \
+ $(use djvu && echo CONFIG+=usedjvu) \
+ $(use hunspell || echo CONFIG+=nohunspell) \
+ $(use pdf && echo CONFIG+=usepoppler) \
+ $(use qml || echo CONFIG+=noqml)
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install
+ einstalldocs
+
+ docinto html
+ dodoc manuals/*.html
+
+ insinto /usr/share/qt5/translations
+ doins translations/${PN}_*.qm
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}