summaryrefslogtreecommitdiff
path: root/app-editors/vim-core/vim-core-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /app-editors/vim-core/vim-core-9999.ebuild
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'app-editors/vim-core/vim-core-9999.ebuild')
-rw-r--r--app-editors/vim-core/vim-core-9999.ebuild17
1 files changed, 14 insertions, 3 deletions
diff --git a/app-editors/vim-core/vim-core-9999.ebuild b/app-editors/vim-core/vim-core-9999.ebuild
index 49bba1db86db..1aeb3a66d543 100644
--- a/app-editors/vim-core/vim-core-9999.ebuild
+++ b/app-editors/vim-core/vim-core-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
VIM_VERSION="8.1"
-inherit estack vim-doc flag-o-matic bash-completion-r1 prefix
+inherit estack vim-doc flag-o-matic bash-completion-r1 prefix desktop gnome2-utils
if [[ ${PV} == 9999* ]] ; then
inherit git-r3
@@ -23,6 +23,8 @@ LICENSE="vim"
IUSE="nls acl minimal"
DEPEND="sys-devel/autoconf"
+# avoid icon file collision bug #673880
+RDEPEND="!!<app-editors/gvim-8.1.0648"
PDEPEND="!minimal? ( app-vim/gentoo-syntax )"
S=${WORKDIR}/vim-${PV}
@@ -201,14 +203,23 @@ src_install() {
fi
newbashcomp "${FILESDIR}"/xxd-completion xxd
+
+ # install gvim icon since both vim/gvim desktop files reference it
+ doicon -s scalable "${FILESDIR}"/gvim.svg
}
pkg_postinst() {
- # Update documentation tags (from vim-doc.eclass)
+ # update documentation tags (from vim-doc.eclass)
update_vim_helptags
+
+ # update icon cache
+ gnome2_icon_cache_update
}
pkg_postrm() {
# Update documentation tags (from vim-doc.eclass)
update_vim_helptags
+
+ # update icon cache
+ gnome2_icon_cache_update
}