summaryrefslogtreecommitdiff
path: root/app-editors/xemacs/xemacs-21.4.24-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-15 17:25:28 +0000
commit6b933047f46efec1aa747570f945344254227457 (patch)
treea12a4b87b38f954c4de435272cf4b90d721df5e8 /app-editors/xemacs/xemacs-21.4.24-r1.ebuild
parentf45955e60d4da9b7f4a1088c98042f9c06669039 (diff)
gentoo resync : 15.12.2017
Diffstat (limited to 'app-editors/xemacs/xemacs-21.4.24-r1.ebuild')
-rw-r--r--app-editors/xemacs/xemacs-21.4.24-r1.ebuild22
1 files changed, 10 insertions, 12 deletions
diff --git a/app-editors/xemacs/xemacs-21.4.24-r1.ebuild b/app-editors/xemacs/xemacs-21.4.24-r1.ebuild
index 4b120d8e087d..6975de5d4292 100644
--- a/app-editors/xemacs/xemacs-21.4.24-r1.ebuild
+++ b/app-editors/xemacs/xemacs-21.4.24-r1.ebuild
@@ -1,14 +1,13 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# Note: xemacs currently does not work with a hardened profile. If you
-# want to use xemacs on a hardened profile then compile with the
-# -nopie flag in CFLAGS or help fix bug #75028.
+# Note: xemacs currently does not work with position independent code
+# so the build forces the use of the -no-pie option
EAPI="5"
WANT_AUTOCONF="2.1"
-inherit autotools eutils flag-o-matic toolchain-funcs
+inherit autotools eutils flag-o-matic toolchain-funcs xdg-utils
DESCRIPTION="highly customizable open source text editor and application development system"
HOMEPAGE="http://www.xemacs.org/"
@@ -86,6 +85,10 @@ src_prepare() {
src_configure() {
local myconf=""
+ # Can't build with pie. See bug #75028
+ test-flags -no-pie >/dev/null && append-flags -no-pie
+ filter-flags -pie
+
if use X; then
myconf="${myconf} --with-widgets=athena"
@@ -156,14 +159,6 @@ src_configure() {
myconf="${myconf} --without-database"
fi
- # fixes #21264, this should be fixed in 21.4.21 and has been fixed
- # in 21.5 for sure. Now that 21.4.21 is out there is no real
- # evidence that this indeed got fixed, so keep these exceptions
- # for now.
- use alpha && myconf="${myconf} --with-system-malloc"
- use ppc64 && myconf="${myconf} --with-system-malloc"
- use ia64 && myconf="${myconf} --with-system-malloc"
-
# Enabling modules will cause segfaults outside the XEmacs build directory
use ia64 && myconf="${myconf} --without-modules"
@@ -184,6 +179,7 @@ src_configure() {
--compiler=$(tc-getCC) \
--prefix=/usr \
--with-ncurses \
+ --with-system-malloc \
--with-msw=no \
--mail-locking=flock \
--with-site-lisp=yes \
@@ -237,9 +233,11 @@ src_install() {
pkg_postinst() {
eselect emacs update ifunset
eselect gnuclient update ifunset
+ xdg_desktop_database_update
}
pkg_postrm() {
eselect emacs update ifunset
eselect gnuclient update ifunset
+ xdg_desktop_database_update
}