summaryrefslogtreecommitdiff
path: root/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-24 16:33:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-24 16:33:11 +0000
commitfaddeff65d652bda3291eba255955adb17f1aa19 (patch)
tree4352e6d85ce48c7c8d96159fad4d3dd90602a70a /app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0.ebuild
parent0e7b1da874d923b9f006e0000023f5fa528140a8 (diff)
gentoo auto-resync : 24:11:2023 - 16:33:11
Diffstat (limited to 'app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0.ebuild')
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0.ebuild
new file mode 100644
index 000000000000..a3f1bb036466
--- /dev/null
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.3.1.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+WX_GTK_VER="3.2-gtk3"
+inherit autotools wxwidgets xdg
+
+DESCRIPTION="XML Copy Editor is a fast, free, validating XML editor"
+HOMEPAGE="https://xml-copy-editor.sourceforge.io"
+SRC_URI="mirror://sourceforge/xml-copy-editor/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 -ppc ~x86 ~amd64-linux ~x86-linux" # -ppc due SSE2 requirement
+IUSE="aqua nls"
+
+RDEPEND="
+ app-text/enchant:2
+ dev-libs/libxml2
+ dev-libs/libxslt
+ dev-libs/xerces-c[cpu_flags_x86_sse2,icu]
+ dev-libs/libpcre
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ default
+
+ # bug #440744
+ sed -i -e 's/ -Wall -g -fexceptions//g' configure.ac || die
+ eautoreconf
+}
+
+src_configure() {
+ setup-wxwidgets unicode
+ econf \
+ --with-gtk=3.0 \
+ --with-wx-config="${WX_CONFIG}" \
+ $(use_enable nls)
+}