summaryrefslogtreecommitdiff
path: root/app-editors/xmlcopyeditor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-editors/xmlcopyeditor
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-editors/xmlcopyeditor')
-rw-r--r--app-editors/xmlcopyeditor/Manifest2
-rw-r--r--app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3-r1.ebuild19
2 files changed, 10 insertions, 11 deletions
diff --git a/app-editors/xmlcopyeditor/Manifest b/app-editors/xmlcopyeditor/Manifest
index 875e7e159f03..230374da7cc7 100644
--- a/app-editors/xmlcopyeditor/Manifest
+++ b/app-editors/xmlcopyeditor/Manifest
@@ -1,4 +1,4 @@
AUX xmlcopyeditor-1.2.1.3-no-automagic-enchant.patch 597 BLAKE2B fe33a2ca16954fbfad90b19edb6c9e161fda4fc26650a4cccbe717bc23143dc54fe5689b83e135f16d1e3fc57c8794eb01e2760db927917fd1f858140d712d5b SHA512 e859277afe276a2e358a011a7c1a9d61e554463ebbe79985bcc159b49495eec076f24595b3b43ae3a3210797f59a92b9944f1a59754556a8322a9ec1d0d5d7d3
DIST xmlcopyeditor-1.2.1.3.tar.gz 4266907 BLAKE2B 52e8c27a37edbcc0da46b52443f5b6754252a62f1abb7746e724270dd5cd9a2db4de60e68d495008ef55a18e9c25149825c9b26c5fd6e20d8e3937931de64e74 SHA512 1adda58bc262cd22898ba22eed3cad9f4a51f199e779172af2d51c5d7bf6dac072b9015b90906236de83d7acebe29d0aae6ae73998ec9d9b3c58b02f081e0b4d
-EBUILD xmlcopyeditor-1.2.1.3-r1.ebuild 882 BLAKE2B 352b538f0637fbdec5efd8c34029b25f9c74b05c6ca20363e5a03a48ab80ba7042c037bf3dd291708157d4426249932e3e3243d4fe409009db8f25423537a025 SHA512 94ece0feba37eb20e255e9305de6925b615b340e1d98c9cc071590a81e85b53e9a0d178aff2350ad7fab52c59bbf64c1c57dd4a2b403b9f9fd9f3b3dfba2e192
+EBUILD xmlcopyeditor-1.2.1.3-r1.ebuild 929 BLAKE2B e7cf454f41a7d9b4b8817b041356b9d8d6a99859fa8be27e7169bc64c13e25943fb982ebfca3888b6e7ff140dd0ec051db99f63469040ca81fc10e50453d22e9 SHA512 a0e4a5ea8048f4c8ab20764167ff36516135e01ab1c3faf4660acf98a36cf98e4dfb16f3c570cca613bff7474822558368dc9fae7634ce6d13952bbd2483d94c
MISC metadata.xml 250 BLAKE2B 113a0d77e4ddd91ae5487bc89371d2973202f242a3c9a8899725295e62b51c0a64437ab158b40ba410c671f92fe3efb896b1446f7301e1f1e923baece1cb7e04 SHA512 20703a39d4150e2a8984fdaeb997da464e98e6abc363e5e07fee46954d5af19c861e40648fb238b763420349e3ebeaa4bf61a621ccff3ff77d6e629c61095bb0
diff --git a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3-r1.ebuild b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3-r1.ebuild
index 08f5b2c7e7a9..740c3a09313e 100644
--- a/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3-r1.ebuild
+++ b/app-editors/xmlcopyeditor/xmlcopyeditor-1.2.1.3-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-WX_GTK_VER="3.0"
+EAPI=7
+WX_GTK_VER="3.0"
inherit autotools wxwidgets xdg
DESCRIPTION="XML Copy Editor is a fast, free, validating XML editor"
@@ -21,12 +21,10 @@ RDEPEND="
dev-libs/libxslt
dev-libs/xerces-c[icu]
dev-libs/libpcre
- x11-libs/wxGTK:${WX_GTK_VER}[X]
-"
+ x11-libs/wxGTK:${WX_GTK_VER}[X]"
DEPEND="${RDEPEND}
- dev-libs/boost
- dev-util/intltool
-"
+ dev-libs/boost"
+BDEPEND="dev-util/intltool"
PATCHES=( "${FILESDIR}"/${P}-no-automagic-enchant.patch )
@@ -36,10 +34,11 @@ src_prepare() {
# bug #440744
sed -i -e 's/ -Wall -g -fexceptions//g' configure.ac || die
eautoreconf
-
- need-wxwidgets unicode
}
src_configure() {
- econf $(use_enable nls)
+ setup-wxwidgets unicode
+ econf \
+ --with-wx-config="${WX_CONFIG}" \
+ $(use_enable nls)
}